No camera view available on DJI Phantom 3

Hi. I have just bought a 2nd hand Phantom 3 advanced. I really need help. After downloading DJI go to my phone i can start the drone but the camera does not show and it says disconnected on screen. I have tried a different lead to controller. Tried using a different phone. Followed instructions for reconnecting but no joy. Now the drone will not start either. Is there someone in the Chippenham area who could help. I am happy to pay if someone can get it running.

Is the camera itself at fault?

Any errors popping up in the app?

Try taking a few photos (while on the ground), do they get saved to the SD card ok?

1 Like

Did you test the drone before you bought it? did the camera work then?

1 Like

Hi. It all worked from the person i bought it from’s phone. What i really need is someone to meet up and help as i am a proper tech phobe. I think in needs a software update. I think the last owner had older version of dji go which matched the version on the drone. As said it would start and fly when i got it from my app but saying not conected. Now will not even start after me meddling with it.

The P3 Advanced and Pros had problems with the gimbal main board that if they go wrong, the camera won’t connect and the drone won’t start. The only way to check is to get another board (rarer than rockin hoss poo) and try that. Sorry mate, better to send it back to him rather than waste your time and money (I know this cos I had the same trouble with a P3Pro).
Get a Phantom 4, much better drone all around.

@Mark999 confirm you’re using the DJI GO3 app and not DJI GO4?

Hi. Yes i am using the G03 app. I would take to a shop if i could find one local to me in Chippenham

The only repair shop we recommend is Drone Doctor:

Saw those thanks. Really want a non postal service. Not sure there is even a fault other than me. I saw this site is run from Tiddlywink which apart from being a great name is just down the rd from me

I had major problems when I first bought a 2nd hand P3A. Exactly same symptoms as you. I went searching internet and ended up changing loads of parts and cables with no joy. A guy in Alaska kindly sent me a gimbal board and that sort of worked but would always be out of calibration. There’s a couple of magnets that are a ball ache to reset that I almost got right. I did get it working eventually but haven’t used it since I got my Mini 2.
I asked a few drone fixer places to look at it and they mostly said they would not take it on if it was a damaged camera/gimbal.
Be careful when doing updates to the drone as they have a tendency to overheat the gimbal board. Always point a fan at the drone if doing update from the memory card.
Hope the guys here don’t take offence if I direct you to the American site that is Phantom Pilots. You will find an extensive archive of posts with your very problem. I will have a rake through my old photos as there is a very handy guide to analysing problems on the old Phantoms.
Advice I would give just now is don’t go diving in changing and updating loads of stuff as you can definitely make it worse. If it was working with the guy that sold it, it could be that it isn’t binding properly. You also have to not update the drone without updating the RC if I remember correctly.
Link below will get you started with Phantom Pilots.

Good luck as the P3P is a great drone once they are working.

Thanks. Just charging everything. I will delete and reload the app. I like to be positive. It worked so will work again.

Hi Mark, just having another flashback. When you go to turn on the drone, do you have a freshly formatted micro SD card in the camera board slot? If it is the same sd card that the previous owner gave you, remove it and stick it in a laptop to check which files is on it. If it has Firmware files on it, copy these to your PC desktop then format the micro so card before returning it to the camera slot. Once you have that done, open the DJI app on your phone, connect the phone to the controller and switch on controller, then switch on the drone.
If there is still no image transmission, let us know and I will point you to a page on Phantom Pilots that describes how to search the hidden log files that the drone will write to your micro so card.

Hope this doesn’t scare you :flushed: Work your way through the flowchart to help diagnose the issue. Bet you wish you purchased a Mini 2 now.

Or it could be as simple as a device/cable/app issue (especially as it was working so recently on owners device)

Hi all. I am sure everything you are all saying makes sense to you but my knowledge of computers etc ends when i push start.
Just to confirm. I have deleted and re loaded app. Charged both the controller and drone. The rear lights on the drone flash green. The light on both controller and drone are Green. The done will start and even take off. The map on app shows my location. The camera moves up and down. All above works.
The camera view onto my phone does not work and the app shows not connected. There is no use in saying download this or that. I do not have a a laptop to do this.
I guess my question should have been. Is there someone who can give me physical help with this near Chippenham.
I dont think sending it away will solve my problem.

I agree, my post above is to make sure there is no firmware files on the micro sd card as the bird starts up. I think it’s a binding/linking issue as it was previously working.
The P3A was terrible for updating firmware and then trying to relink.
Is the guy you purchased it from local to you? If yes, ask if he would be willing to try linking to it again, that would confirm it’s just a connection problem you are facing.
Sorry I can’t offer any hands on help being stuck so far north, just chucking out some suggestions.

No he is a long way away. It was a good thought though i am right in thinking it should connect even indoors.

yes you are able to connect indoors. Just don’t start the thing up with the propellers connected like I did in my living room. I can still hear my daughter and wife screaming as it started up and it tried to go to the set hover height. I shat myself and grabbed the legs, but the drone seen that it couldn’t get to hover height and went full power. I couldn’t shut off the controller as i was holding on to the drone… there was carnage everywhere.
If you remove the props, you can start the drone up and the motors will spin away and you can test the throttle.

If you go for a start up, are there any bleeping noises or tiny flashing LED just above the camera?
The bleeps are a code to trouble shooting and if everything is okay i think the LED flashes through a green sequence. Flashing red and bleeps means there is an issue.

Mark, have a quick look at the YT video below. Might help.

I did make it take off in my lounge. Landed it but wont be doing that again