Noob in fpv needs help from real live person please

First Post not sure I’m doing right. Bought all the fpv gear with no idea. Is anyone around Burton on trent willing for me to meet them and pick there brains please.


Hi Brad. Firstly welcome to the Forum.

The world of FPV is pretty confusing but hopefully the collective minds can help you on here.

We also meet fairly often and not a million miles away from you.

However I’d suggest to help you deal with your issue it would be useful if you could give a summary of the problem/s you are having and we can try and find a solution.


Yeah man, welcome feel free to ask any questions and we’ll do our best to answer them :+1:t2:


I’m struggling to work this platform. I need someone to walk me through pairing my new controller goggles n quad please. I need showing myself I can’t sort the issue as no idea where to start. Got 3 quads all not flying but work fine.

1 Like

Welcome Brad and you’re in good hands with these guys, there isn’t much they don’t know about with regards fpv :+1:t2:
What quads, controller and goggles have you got for starters?

1 Like

Right then guys would any of you be willing to meet me tomorrow evening please.

Skyzone o2c goggles jumper T8SG V3 plus although the sticker on the back days v2? Also I have the eachine qx65 I got today that now hasn’t got a bind button like everyone on YouTube that reviewed it. It says use the cli I tried all day with dsm2 and dsmx and nothing. I don’t know what I’m doing at all. All the gear no idea. Also got hubsan h122d x4 storm that switches on beeps but won’t arm n ez pilot Also the same as hubsan

I’m wondering if you purchased the QX65 without a receiver? Also known as a PnP. Can you post a link of where you purchased it?


No bind but says put in the cli set spectrum sat bind blah blah. Tried for 6 hours.

It has the dsmx and dsm2 reciever the instructions say to bind do that cli thing. Look on banggood buddy at qx65 n it says in the product details no bind button use cli tag thingy

What does? The instructions that came with it? Is it recognised in Betaflight ok when you plug it in?

1 Like

Yes it connects to betaflight but there’s where the issues begin. Also brand new controller and not sure I’ve done that right either. Its hard trying to use YouTube to fix it

Got another better drone on way n no idea on that 2

Have a read of this. Apparently Betaflight V4.X they removed the spektrum binding through CLI ? Don’t know how accurate that is but what version of Betaflight is running on the quad?

1 Like

No idea what’s that?

Can someone meet me to help me please going around in circles on here isn’t helping it needs someone in the know to waste a bit of time helping me please

Eachine become v2.0 version. Can’t find version of betaflight sorry

1 Like

You would need to plug your quad into betaflight to check what version you are running.

Sorry Brad I’m right down in the south east (kent) so I can’t come to meet you I’m afraid. One of the other guys that live closer might be able to though :crossed_fingers:t2:

1 Like

No worries mate. I will keep trying.

Hi guys. I have skyzone goggles jumper T8SG plus controller and have a qx65 a amg65x with another quad on order. I’m looking for someone that is from the Staffordshire or Derbyshire area that can meet me and help me get set up please. I’m desperate to use my quads and get out there learning but at the moment I’m grounded with only a dodgy old laptop trying to use a sim. This hobby sure is different to flying my dji kit.