Old Mavic Pro... Error?

Looking for a little advice… DJI Mavic Pro

My Mavic Pro Alpine has been working perfectly well since dusting it off a few months ago. On Thursday 25th January it threw up an error on the controller… “No Props” during flight. I hit the ‘Return To Home’, it flew back at 280ft without any problems and landed perfectly with 67% battery power.

Assuming it was a prop problem and an easy fix I put on a set of ‘Master Airscrew’ Props from my other Mavic Pro (Platinum) which did fix the problem initially, but again during a a short low level flight this morning it came on again. I did RTH without a hitch, as before, it came back and landed perfectly with ample battery power.

I’ve calibrated everything, following the usual ‘step by step’ precudres that’s usually offered as advice on Facebook Discussions, I altered the gain settings in accordance with advice from another flyer (based on Master Airscrew Orops ru. Ing at a lower RPM) to no avail. I’ve now reset the gain to it’s default set. I’ve used contact cleaner on all motors, then blowing out the residue with compressed air, I’ve spun all the motors in isopropyl again on advice. I’ve checked for any irregularities in the motor balance, all of the motors are straight with no wobble or play, and all the props are secure with no play. I’ve now re-installed OEM Props.

All the batteries are in excellent condition, the charging cycle on my three batteries are 222, 97 and 16. I used all these batteries on my recent test flights since the error appeared. I’ve rolled back the firmware four times via Assistant 2… still the error persists.

I contacted DJI who requested the logs of both flights. They couldn’t identify the issue as a mechanical “motor idling” fault as the motors were running at the correct revolutions, in-flight with props . They suggested it may be a “sensor”, controller fault or firmware glitch that may be the problem. I contacted ‘Drone Doctor’ for a second opinion thinking I may need to send it in for repair, however I was again told “it was probably a firmware Glitch” and has been identified on other Mavic Pro’s, and as such I shouldn’t worry about it.

I’ve flown it with Litchi as well as DJI GO 4 and both threw up the ‘motor idling’ error, yet there’s nothing wrong with the motors as they all spin at the correct speed and the Mavic flies faultlessly in all modes, even though the error states it’s flying without propellers.

I know it’s an older drone, but it’s a well maintained and trusted flyer in mint condition, and although I have much better drones I’m reluctant to part with it as I use it as a ‘Traing Drone’ for my Wife and Daughter (both recreational, certified flyers).

Sending it away for a look over by other Drone repair companies will probably cost more than it’s worth.

Has anyone else had a similar issue, and if so have you found a solution?

I believe I had a similar error many many many years ago, followed by the Mavic crabbing as it flew.

The error it seems is due to a single or multiple motors but usually it’s a single motor’s current being sensed out of the set range.

Hopefully if it’s crabbing, you can find out which motor it is with one of those laser thermometer which I used to diagnose mine, which turned out to be one motor having a higher current draw than the others.

On replacing the motor which required the replacement of the entire arm, it’s be fine over the last few years….


I’d never wash a motor with alcohol, it flushes the oil out of the bearings, WD40 sparingly.

One of these…

ERICKHILL Infrared Thermometer -50℃~600℃ Compact Size Non-Contact Laser Thermometer Gun LCD Backlit Digital Display Adjustable Emissivity - for Vehicle Repair/Cooking/BBQ/Freezer/Food, Black Blue

Rollback on the MP is very easy, knock it back to .700 and see if it persists.

A couple of years ago the downward sensors on my MP suddenly stopped (I discovered with a pretty hard landing).

I re-flashed the firmware and it’s been fine since.

1 Like

Thanks for the advice. I’ll probably use this as my last option as I’d rather nit unvest any mire money in to something that may end costing me more than it’s worth.

I’ll re-lube the motors, something I should have done after the rinse, so thanks for that reminder. It probably is a motor pulling mure current… that makes the most sense based on the issue. I’m reluctant to spend much money on this drone.

Re-flashing is something I’ve tried… unfortunately there’s no change, based on that the issue has to be mechanical in nature. I don’t really think it’s worth the investment to repair considering it’s age and resale value, even if it didn’t have an issue. Shame though!

I wish it were that simple. I’ve tried rolling it back three times, unfortunately it’s not a firmware problem it would seem. It’s looking more likely to be a physical issue. It’s odd DJI didn’t think it was a mechanical fault. They did state quite categorically “it’s no longer supported”.

It would seem it’s fallen in to the “classic” catagory.

About 2020 :frowning:

Still love mine don’t fly it as much as I should