Setting output power of the TBS Tango 2

Since I upgraded to crossfire Iv found I have a real black spot if I fly round the back of me. Never got this issue with vista?, its so bad Iv had a quad drop out of the sky :astonished:

1 Like

What power are you running your tango2/rx at?

Is there anyway of boosting the signal from me Tango2 ???

  • Press and hold the menu button
  • Click the jog wheel on tbs agent lite
  • Click the jog wheel on tango 2 XF
  • Click the jog wheel on radio settings
  • Make sure you’re set to 868MHz
  • Set max power to what ever output power you want to run at. (but to keep things legal it should be set to 25mw)

There seems to be a typo on my radio though as theres a 0 after the 25 :wink: So I’ve logged a ticket with TBS support. :stuck_out_tongue_winking_eye:

Pmsl cheers mate :+1:t3:

turn on ‘Dynamic Power’ :thinking:

Yeah, good shout @Steviegeek I use dynamic power too :+1:t2:

How far away were you when you had the failsafe?

Not far 30 feet or so :person_shrugging:t2:

In Betaflight???

No, on your Tango 2. will be in the same place as your output power. under radio settings.