Strange date/time on P3 Pro


I’ve had my P3 out again today and I noticed the date/time is odd on the photos/video.

‎01/01/2098, ‏‎00:00:10

That is the timestamp on the file and the EXIF data. I have had a search but cannot find and answer apart from someone saying swap out the gimbal board (excessive).

Date/Time on the tablet are fine. Any ideas please?


Interested as just bought a P3 mate, will be watching this thread.

I have tried everything and still has the same date and time for each photo/video

I can cope with it but it is rather annoying.

Have you tried a different phone/tablet?

To the best of my knowledge, I thought DJI drones get their system time from GPS?

1 Like

On the rare occasion the CrystalSky battery goes flat and I forget to set the time and date on it (only twice so far), the photos are time stamped with whatever the CS defaults too.

Which granted, isn’t 2098 as per OP.


I’ve flown a few times without any phone (in a frigging hurry to catch something) … all the images/video were in the correct date sequence and with correct exif data. :man_shrugging:

1 Like

According to a post over at DJI forums where exif data was wrong, DJI stated it is set by the device clock.

Not sure how that would work flying without a device like you said though Dave.

DJIs suggestion of checking phone was set to Auto time/date did not help the poster in that case.

Could just be differences on a P3 vs a current-gen firmware?

Hmmm - it might depend upon if the battery has continuously been in place since last set … and retains the info.
Just chucked a battery in the MP and not used a phone.



Oh good spot!! :bowing_man:

how do I change this please? what do I need to do? The battery isn’t in the P3 continuously

Nor is it in mine. I was only suggesting how, in the past, I’d had correctly dated/timed files without the phone attached. Normally I fly with a dedicated drone-phone.

Since you bought the second-hand P3, have any of the photos/videos been correctly dated?
If not, then there’s always a possibility that there’s an issue with the P3.
If some have been correctly time stamped, then I think this is unlikely.

So - what we have determined is that the system date on a DJI drone is set from the attached tablet/phone.

So - were I you - I’d do the following to try and identify the cause of the problem …

1 - If you have another phone/tablet - try this. (You don’t even have to fly - you can just switch everything on in the house and take a photo - as I did last evening for the above test.)

2 - Try using a new(different) USB cable between controller and tablet.

3 - Uninstall the software on your tablet and then reinstall.

1 Like

ok I tried all of that and exactly the same and I’ve not had one dated correctly. Rather annoying but I did get the P3 Pro, case and camera protector for £150, which is a decent deal. So if there is no fix, I can live with the wrong date/time stamp. I’d rather not obviously…

some were taken last night and some just now…

1 Like

The only next step would probably be re-flashing the firmware … but I’m not someone that feels confident enough to advise on that. Someone else might … or there’s probably a TouTube “How To” that you could follow.

I’ll give the reflashing a blast. cheers

1 Like

reflashed… tried a different SD card… Same problem. I guess something is broken somewhere…

1 Like

That’s a nuisance.