The transplant was a success but the patient is behaving erratically

As I slowly raise the throttle (no other inputs) it reaches a point where it just yaws and cuts out.
If I slowly apply some roll (before take-off), it will start rolling in the correct direction and then start rapidly rocking from side to side until it cuts out.
Clearly something is wrong and instinct tells me it’s to do with orientation sensing somehow.

This all flew perfectly when it was in the 3D printed Nano Long Range. Differences (aside from the new frame) are:

  • It is now powered by a 2S LiPo, so no 5V uplift required
  • The FC has been flipped - it was technically upside-down in the Nano

I have checked

  • The depiction of the quad moves correctly in BF\Setup, so I assume I have re-calibrated the gyro correctly
  • The motor order is correct
  • The motor directions are correct
  • The props are on the right way around (verified in BF\Motors - if I give a single motor some juice the correct corner starts to lift)
  • Controls respond correctly in BF\Receiver

Currently stumped, but I really need to get back to work. :stuck_out_tongue:

You running 4.3? I’ve found strange and flyaway behaviour and have to find tunes (from presets) for quads of different sizes. If the Gyro/Accelerometer are reacting correctly (you checked accelerometer, did you check gyro?) in BF then it could be that rotation is wrong?

Was it 1S before? that might then be the tunes.

No, still 4.2.x

Gyro was set to 180CW initially. I changed it to 0CW to no effect. It’s not like the board is mounted funny, it’s facing forwards.

I’ve never messed with any of that tuning stuff. Previously it was running from an 18650, but it was on whatever the defaults were.

Defaults should be fine for rotation.

But you are running double the voltage which will have an effect I’m pretty sure! My guess is that’s the issue. I’m not expert on tuning though, which is a pain!

Set roll to 180 in the config tab? My yaw is 180 because my fc is facing the back


1 Like

Have you made sure that bf knows whether the props are reversed or not. The little tick box next to the prop direction diagram.

That’s the badger! I was so convinced that the board was upside-down in the previous build but I didn’t’ twig that I hadn’t had to mess with these settings before, so they would need doing now.

We’re up and terrorizing the cat.

It would be nice if I could get the WiFi working for SpeedyBee but although the phone will connect to it, SpeedyBee doesn’t see the device and then seconds later the WiFi seems to disconnect itself. Oh well, something else to dick with later.

Cheers, all. :+1:


Turn on your bluetooth and connect via bluetooth. You only really use the wifi option if you are flashing new firmware Jez :+1:t2:

I don’t think this one has Bluetooth :slight_smile:

Ah my bad I thought you had a Speedybee fc :man_facepalming:t3:
Have you got the latest version of the Speedybee App? Also have you got your location settings turned on? For some reason mine wont connect unless location is active

1 Like

Also check phone settings as sometimes if the wifi device you connect to doesnt have internet access it will disconnect from the network automatically

Honestly, now it’s working I care less about getting WiFi connectivity. The USB connector’s an arse to get to so I was getting fed up with it. :slight_smile:

Had a quick bez around the park across the road just to make sure. Unfortunately I’d forgotten to charge my goggles so I only managed 5 min and the video I took was corrupted. D’oh!