Trouble updating 'Safe Fly Database'

Got the Mavic out today after not touching it for several months.
As usual fired it up in the house to check everything OK. I fly with an iPad and once the DJI software had connected to the drone, it asked me if I wanted to update the ‘Precise Safe Fly Database’, I guess because of the new regs about no-fly zones.
So I said yes, it came up with the Download Now button which I clicked. It appeared to start, showing 0% downloaded then immediately changed to ‘Continue Downloading’. and it won’t budge. Every now and then it accepts a touch on that button, shows 0% again and goes back to ‘Continue Downloading’. Wifi network is good and the internet connection is fine. Ipad is running iOS 13.1.3.
Now, my house is probably within 3 miles or so of a small farm airstrip. Is the software refusing to go further because I’m maybe in a ‘no-fly zone’? It’s the only thing I can think of.

Actually it just occurred to me to look on the DJI site for the zones. Although it marks the farm strip, there is no zone marked around it. So I guess this problem I have is software?

Strange as it may sound, people have reported success by switching off WiFi and installing the updates over the mobile network.

Bizarre, right? :man_shrugging:

Worth a shot though mate.

Thanks for the suggestion. Yeah, bizarre!
Anyway I tried again this evening via wifi, and it worked perfectly. I’d think there was a hang-up on DJI’s servers when I tried before.

2 Likes

Ok glad that you got it resolve now please mark this thread as resolved