Unable to import MP4 to Final Cut Pro

Hi Guys

I’m a total newbie and a total newb with FCP although I have been using Adobe Premiere Pro. So please forgive me if this is a lame question, I’ve tried searching but can’t find anything that relates to my problem. I suspect it is a user error (down to me). But after two hours of searching and changing some settings still no Joy. I am trying to edit my Drone footage with little success.

I have made one video with no problems edited it, even added an audio track. I then decided to have another bash. I, therefore, started with New Library/new project. named it local.

I then try to add media and my collection of MP4 vids are all ghosted. the only media available is 2 .jpg files. See attachment

For Info: I’m using FCP 10.4.3 All my files are on an external hard drive, named studio, having been downloaded from the MicroSDHC Card. I have other folders with MP4 files, on the same external hard which were taken on my iPhone using My DJI Osmo3. I can import these, but not the MP4’s from my Mavic Pro and I have not changed any settings on my Mavic Pro.

I suspect I’ll kick myself when someone points out my error


Are the ‘greyed out’ files all ones you used in your previous edit?

1 Like

Hi milkmanchris

No this is totally new footage taken 7 weeks after my first attempt. I am going to try a hard reset on my Mavic 2 pro to see if this helps. However it has not had a crash nor any issues prior to this. Hence why I’m at a loss

Do the files open in preview on your Mac.

Are they H264 or H265 ?

1 Like

Do they import to iMovie ok? :thinking:


Play in Quicktime no problem whats so ever I have done a full hard reset so will try to record later it’s just it is chucking it down now and I’m on nights tonight. trying it indoors gives a real grainy/noisy image

Yeah but if it imports all is good (again)

1 Like

H265 is the problem. You’ll need to either transcode to h264 or proRes using EditReady, Compressor or something else. Or upgrade to a newer version of Final Cut Pro.

10.6.1 should be fine.

I would agree with you on that as all the files import into Premiere Pro no problem. I didn’t think I had changed any setting on my Mavic but I must have. As now I think about it. I did have it on H264. As I’m using my old 27” inch iMac which is a Mid 2011 32Bg Ram and it runs brilliant but can upgrade past High Sierra. Hence the 10.3.4 I use as I can never get on the new due to the kids :joy:. So I kept this machine just for me. Will give it a whirl in the morning when I get home

Thank you

Ok Guys

Thank you to everyone who replied to my post. As “ensignvorik” pointed out the issue was H265. Final Cut Pro 10.3.4 cannot Handle H265. So I make have to look at investing in a new MacBook.

When set to H264 you cannot select DLog-M or HLG in colour mode. Not sure if this is detrimental just yet. Given I always enhance saturation and a few other settings anyway and as I pointed out above if I need H265 I can import into Premiere Pro for the time being. Therefore I’m in no rush to run out and spend £1.5K on a laptop to do the job.

For now, at least I can continue to use FCP on this machine while.

1 Like

As I thought h265

Bit you could always import them into compressor and export to something that will work