Video rendering error: 10008 (iMovie error 10008: renderVideoFrame failed)

Just spent 2 hours editing some DVR Footage from my Tiny Whoop only to get this error:

Video rendering error: 10008 (iMovie error 10008: renderVideoFrame failed) when trying to export it.

anybody have any idea how to get around this? or have I just wasted 2 hours of my life :man_facepalming:t2:

Mine was fatal :confused:

Do a search on here for 10008.

Bottom line, dropped frames. You should be able to see them if you advance it frame by frame.

Drove me absolutely insane.

It’s analogue DVR footage recorded from my fat shark goggles so there are 100s of dropped frames and fuzzy areas where the VTX drops due to obstacles between the VTX and the RX of the goggles. :disappointed: So i guess i’ve just wasted my time :man_facepalming:t2: doh! :rage: lol

It was exactly that mate, I spent hours last night picking out the dropped frames :man_facepalming:t2: :joy: I never want to have to do that again! :rofl:

1 Like

This sounds like your DVR is creating faulty files. I’ve only had this (albeit when using Davinci Resolve) with a video where recording wasn’t stopped before powering off.

However - this was easily solved.

Before editing, I used a re-muxer to create a “good” video file, and then edited this.

A re-muxer? … a program that creates a new video from an existing one … usually to change some aspect of packaging and/or codec … but can be used to create a video with identical packaging/codec.

I’m Windows only - but I know some of these are multi platform …

  • Handbrake
  • Avidemux
  • VLC Media Player (yes - it can do a lot more than just play video files!)

Easiest of those to use for this requirement (creating a good copy) is probably Handbrake … but most people have VLC

VLC …

  • Open VLC

  • Select “Media” from the menu bar, and then “Convert/Save”
    image

  • Select your source file

  • Click the “Convert/Save” button, and then select “Convert”

  • Select the required profile - probably the default (chances are .mov is alsi available on Mac)
    image

  • Enter “Destination file” location and name, and then click “Start”.

Hopefully something from above will help.

Of course … there’s always a possibility that with your exact issue that VLC will throw a wobbly.
Worth trying to find out if it’s a quick solution for another time.

Nice one, I’ll check that out if I run into the issue again :+1:t2:

1 Like