Way to force FCC mode on inspire 1?

Hello all,

Now I’ve had time to play with my i1 and also introduce it to the ground hard, does anyone (looking towards the master of the i1 @PingSpike) know if there is a way to force the i1 to FCC mode. I have tried the GPS hack on my android phone but that doesn’t seem to of made a difference that I have seen(I’m expecting to see the pop-up correct?)

Any help on this would be great as flying just over 1km and can still be VLOS I’m getting signal error and the auto RTH kicking in so wondering if this may be a fix?

Have you got Litchi?

I have a feeling it’s the GO app that forces you in to CE mode, flying with Litchi may leave it in the default FCC mode :thinking:

Don’t buy it yet, I may be wrong, it’s been a while since I looked at this, let me see what I can find our later today.

When I was younger and irresponsible I was a member of a DJI Facebook group, it may have been the Spark one. Within that group, in the file section, was a modified version of the GO4 APP that when used would force the drone into FCC mode.

I went the firmware editing route with my Spark to permanently enable FCC mode. I think I used a combination of the Dumbldore utility and the editable version of the Assistant2 APP. I’ll need to check my old laptop to see exactly which utility I used.

Don’t forget the Inspire 1 and Phantom 3 are the previous generation though @Nidge

They’ll be using GO3 and they have very different parameter mods from the Mavic Pro /
Inspire 2 / Phantom 4 / etc.

You could mod the GO3 app though, if you’re willing to roll your sleeves up and learn some stuff @M6SSO

1 Like

Doh :persevere:

may be my only option time to google then

If you want to mod the firmware directly, rather than modding the GO app, start here @M6SSO

And if you want to mod the app, here’s a virgin nosecneo version that you can decompile :wink: