Zenmuse Z3 transmission lag on Inspire 1 possible fix!

This may be useful to anyone with an Inspire 1 with Z3 lag issues,

I recently acquired a Z3 for my Inspire 1 v1 and i also have the original X3.
I swapped cameras over and did a little testing indoors and all seemed well.
Next day I ran through 4 batteries at a local beauty spot and was very happy with the performance of the Z3.

Without touching anything other than charging my batteries I went out again a few days later and had nothing but trouble!

Powered everything up as usual and everything seemed ok took off but within seconds I noticed I was getting considerable video transmission lag to my Ipad screen.
Brought the bird down checked everything, re attached the Z3. Checked all my settings but nothing had changed.

Tried again and initially it looked better but the longer it was turned on the lag fairly rapidly increased again. I am talking serious lag 10 seconds or more.

I swapped over to my backup android device but still the same.

I came home and spent most of the afternoon reading about Z3 horror stories regarding transmission lag.
I tried everything I could find on the net to fix z3 lag and nothing seemed to work. I removed the z3 cleaned connectors etc.

I did notice that when first powered up the lag was relatively low but over a period of a few minutes the lag would increase to 10 secs or more
I did notice my z3 firmware level is which according to the DJI download page is Z3 firmware for the Matrice.
I tried installing which is the listed firmware for the Z3 on an Inspire 1 but it wouldn’t upgrade/downgrade. Log file saying firmware is the same or lower etc.

So finally I re-attached my X3 just to check that was still working and that was fine, virtually no lag and no issues.

I then swapped over to the Z3 again and suddenly no lag!!
I powered down and up again numerous times and its still working without lag. I left it switched on for 20 mins and still the same.

I’ll give it a field test tomorrow and see how it goes but it almost seems to me that re-attaching the x3 reset something which cured the lag for the z3.


ok I put 3 batteries through it today and all lag free. It’s a strange one and needs a bit more work to get to the bottom of it but at least I know I can recover it if it starts lagging again.

Here’s what I’ve been running the last couple of years if it helps:

  • Aircraft:

  • Remote Master: 1.7.80

  • Remote Slave: 1.7.80

  • X3 Camera:

  • Z3 Camera:

  • X5 Camera:

That a/c firmware is pretty old isn’t it?
My Z3 is the same f/w as yours.
Do you ever see any transmission lag using the Z3?

Yes, very :smiley:

I experimented with loads of combinations of firmware versions, and app versions too, while trying to work out what worked the best in all scenarios.

No lag at all, on any of the cameras.

Out of interest, have you tried Litchi?

No never used Litchi.
Are you using latest DJI GO app? and is that on IOS or Android?

I’ll have a look and see how I can downgrade firmware on the A/C and give your setup a try

Hell no :rofl:

Litchi on a rooted CrystalSky all day long.

And prior to that, probably an old custom rolled version of GO3 :thinking:

Ok cheers
I’ve been reading some of your articles on Inspire mods.
Nice work. Good to know someone who knows what they are talking about and has experience.
Thanks again

interesting old thread as it the solution found by changing cameras over is exactly my finding as well,
I am on different versions of software but it the only issue I have and its not consistent either the z3 video lag. I have learned to keep the original camera with me J.I.C.