Assistance please - TBS Crossfire

I’ve managed to ‘brick’ a TBS Nano Diversity Receiver.
I tried to recover it using the reset ‘golden version’ firmware procedure stored inside but either the FW was pre v2.24 or it just fails :frowning_face:

Therefore I’m looking for a kind soul who can loan me, for just a day, any one of these TBS parts which will enable to flash new FW back into it via BST port.

  • Standard 8ch Diversity receiver
  • FPVision unit
  • TBS CORE PRO

Of course, I’ll cover all postage costs etc.

Thanks in advance

Cheers
Steve :slightly_smiling_face:

Where did you for the scrossfire rx from? 2.24 is Errm well over a year old so it’s unlikely to be running anything that old. Can you describe exactly what the problem is and what firmware your running on the tx please?

I have a nano rx, micro tx and a fusion. Any of them useful?

Thanks Karl, but no, none of those will do the job.
It needs a unit with a USB connector and a BST interface port
Cheers
Steve :slightly_smiling_face:

Hi James,
I’ve had the RX about a year, can’t say for sure what version FW it had, but it will not recover with the stored ‘golden’ firmware.
My TX is running v3.21 which is what it was trying to upgrade the RX to.
That is a valid version for both pieces of kit.
All I need is the loan of one of those units and I can put new FW back in the RX
Cheers
Steve :slightly_smiling_face:

I’m pretty sure the div nano can’t be flashed with non compatible firmware. If you want you can arrange to drop it over and I will see if I can get it to talk to my tx.

TBS agent, updates and binding have been a pain in the arse for me. Have you tried rolling back your tx firmware to see if that helps?

2 Likes

Good idea :clap:
I’ll try that tonight, thanks

1 Like

I had to reset my TX Micro to pre version 3 or nothing would bind to it using either the radio lua, the button on the TX and even running the TX on usb and using the TBS app

1 Like

SUCCESS.
I followed Karl’s suggestion, suported by Dave’s comment and further ‘googling’ and with TX downgraded to v2.93 I was able to flash firmware into the ‘dead’ Diversity Nano RX (had to follow tip from TBS Facebook page to quickly power-cycle the RX a few times to get the upload started)
Then found that the RX in my 250 quad would not downgrade to anything (it was at original v3.21) so had everything working but not in harmony.
After multiple tries I’ve ended up with everything at v3.23 (which is the latest flavour in TBS AgentX)

So thanks to you all for your feedback, this is what makes this forum so succesful, everybody tries to help :+1: :clap: :smiley:

@PingSpike Rich, do these guys get any badges for ‘technical support’ ? :pray: :laughing: :laughing:
@notveryprettyboy @evilbobbins @Wyntrblue

Thank you all again
Steve :slightly_smiling_face:

3 Likes

Check this post out @Steviegeek : Even more new badges, and a new feature too!

If you want, we can move this topic to the #questions-and-answers category, you’ll then have the option to choose one of the above answers as the ‘solution’, a badge will then be automatically issued to the person who solved the issue.

Let us know if you want the topic moved?

Man. Tbs updates are an art form! Glad it’s working.

Hi Rich
Yes please, it ought to be moved :+1:

I think I need to study existing categories/threads harder before I post :face_with_hand_over_mouth:
I’m just impetuous :laughing: :star_struck:

Post moved as requested @Steviegeek