Bug when adding a new Location to Drone Scene

Does anyone have this problem when entering a new location on Drone Scene.

  1. Try to fill in all the data requested
  2. Hit the Submit button
  3. Get an error saying "you forgot to complete “…” "
  4. Complete missing entry
    Hit submit button again
  5. Get an error saying “You need to submit a photo…” even though I already uploaded one . .
  6. BUT There isn’t a box to upload (or re-upload) a photo and I have to log out and back in to start ALL OVER Again - Very Frustrating
    I’m using a Mac if that’s any help…here’s a screenshot…

Thanks for the detailed steps to replicate @jon1

We’ve not made any changes to the add-location section for around two years now so it’s surprising to hear of a problem in this section of the site at this late stage of being in production.

Can you just confirm you completed all the data AND uploaded a photo? Then clicked Submit only to be told you hadn’t attached a photo? Then it all went downhill?

Or did you fill some boxes and forget the photo, at which point it all went downhill from there?

With which browser please?

Yes, It’s every time I’ve added a location PS (sorry I don’t know your real name) and forgotten to fill in a required bit of data.
I have uploaded a photo (box shows a “1” in it) before I hit the Add Location button but it then detects a missing bit of data ( no pin, no Permission etc - all my mistakes) so I do that and then get the missing photo error…with no box.
As I’m new to GA/DS I’ve only added about 4 or so entries but I think 3 times I’ve made one or other errors and got the “Missing Upload Box” problem.
I’m using a Mac running the latest Monterey and Safari browser.
I tried refreshing the page and it still doesn’t show the upload box. I can only log off/ back on and do it all again from the start :frowning:

Yes get the same problem on edge.
Have to back all the way out and start again sometimes.
When happened to me i had added photo and forgot to confirm i was outside a FRZ the tried to post. Confirmed the outside FRZ, click post and it says no photo.
Fairly recent phenomenon. Possibly a browser issue as only “noticed” it in the past 12 months.

Yes this problem exists, I’ve seen it myself, but forgot to report it. It’s normally when I forget to tick that the flight was not in an FRZ, and then you end up unable to finish the entry due to the photo error, even though it’s there. You have to start again.


Ok, thanks everyone, added to the bugs list. Will investigate as soon as possible.

1 Like

@jon1 @stevesb @firstadekit I am able to replicate this issue.

Unsure of the exact cause as yet (only just this minute replicated it) but as I can replicate it, I’ll now be able to fix it :slight_smile: