Can't connect Galaxy S10E phone to DJI Mini 2 controller

So I’m sure you’re all glad that my Mini 2 finally arrived.

Bit of a weird issue though so here’s my stupid Mini 2 question.

I can’t connect the controller to my phone. When I plug it in, it doesn’t even start charging. Have cleared DJI Fly cache, reinstalled app and rebooted phone. Still no sign of either controller or phone seeing each other. Controller sees the drone itself and links to that fine.

And in case I’m being thick yes I’m using the right hand port on the controller and yes I’m making sure the phone case is taken off. I’ve even tried the USB-C to USB-C cable both ways with the controller icon on the phone too (not that it should make a difference).

Any ideas?

1 Like

@dulcificum which phone are you using? Which version of android is it running? Which version of the Fly App are you using? Also if you have one, have you tried a different USB-C to USB-C cable? I know its unlikely but not impossible that you have received a dodgy cable.


I tried the USB-C to micro-USB cable with an adapter and it still wouldn’t even charge so I guess I can rule that out. My understanding is that the controller also just works as a charger for any phone?

It’s an s10e on Android 10 and now using latest DJI Fly which is 1.2.1.

I’m thinking it’s the controller itself :confused:

1 Like

There is a newer version of the Fly App available for direct download from DJI V1.2.2 . The link is below courtesy of @PingSpike

Worth trying.

When you connect your phone to the remote does it do anything at all? It may not charge your phone as this is a setting you can turn on/off so not necessarily an indicator (can’t remember if its set to on or off as default)

1 Like

It does absolutely nothing unfortunately.

No dice with v1.2.2 either.

1 Like

So does it not come up with a box saying ‘connect to aircraft’ ?

might sound dumb but have you checked it to be on ? as you can turn it on or off in the settings

Yes, I can navigate to that. But going to “Connect to Aircraft” like usual just gives the three step progress and no amount of plugging in the cable helps.

1 Like

Sorry mate, checked what to be on?

When the controller is on what are the 4 LEDs doing in the middle of the controller?

1 Like

Solid green once they connect to the drone.

Everything is correct according to the manual. Once drone connects to controller it goes slow green. The controller seems fine apart from the USB-C port which doesn’t do anything :confused:


Take the phone out of the loop

Will the controller connect?

They are green on the controller? Maybe different to mine (I have MA2) but mine are white although it is the same controller :thinking:

1 Like

Mini 2 controller is only green I think? Mini 1 and MA2 white afaik. DJI Mini 2 | How to Link the Remote Controller - YouTube

Sorry, what loop? And what do you mean connect? To what?

You do not need a phone to connect the controller to the drone.

Will the controller connect to the drone without a phone.

1 Like

Yes. In OP: " Controller sees the drone itself and links to that fine."

do you have another phone or tablet you can try?

1 Like

Only other device I have here is another phone (not good enough for DJI app) but won’t charge either. I’m inclined to think the phone isn’t the issue as it was fine with Mini 1 last time I tried.

Pass then sorry.

1 Like