DJI Fly - App updates and download links

My mini 2 was at 25% today when I gave it a quick blast down to 10%

So it’s nothing to do with any update that may have been for the mini 2 then chris.
Next update may pop up the message. “Owner must buy the mini 2 to take off”. :grin:

Release notes for v1.2.2

23 December 2020


What’s New?

  • Adds a new Attitude Indicator: Learn more about your aircraft’s orientation and flight info.

  • Adds Flight Tips: View interesting aerial photography tips during scenarios such as firmware updates, taking hyperlapse shots, and when the aircraft is returning to home.

  • Adds the following supported functions for the Customizable Button on remote controller: Gimbal Follow/FPV, Camera Settings, and Exposure Lock/Unlock.

  • Fixes certain issues and optimizes overall app quality.

1 Like

Has anyone else noticed that there Air2 is flying a lot slower since update, Normally flay at around 11m per second in normal, but now down to 7m per second ? and was not windy ?

1 Like

I’ve not updated yet as doesn’t seem to be available on playstore yet

Direct download link, just for you @SirGunner

DJI Fly

1 Like

Thanks Rich appreciate it mate :+1:t2:

1 Like

I typed everything below over a 10 minute period while trying to get my O5 working the version. I’d been going for about 15 minutes when I typed the last line. Take this as a warning that you need to update well before flying…

Installed 1.2.2 from the direct link onto my OnePlus 5, Android 10. The app worked perfectly before, now it runs like a dog. I have also installed the app on a Xiaomi Mi Note 10, Android 10. Both installation processes exactly the same.

On the Mi, all looks well and runs without problem, flight logs visible immediately. The O5 app runs like a dog and the flight logs have gone. Seems fine if I launch and go into Profile, except for the lack of logs, but once you go back to the main screen it hangs for about a minute with Android asking if I want to wait or kill. If I wait it comes back to life, go into a main screen option and it’s OK, back to main screen and hangs again for a while.

Ooh, my logs have finally appeared and the app is running OK.

Oh ****, after a break the O5 is doing the same again. Flight logs gone, Android asking if I want to wait or kill the app, etc. They’ve either increased the base processing power needed for the app or an issue with the O5 which is still listed as compatible with 1.2.2.

A bit more testing and it seems the issue is when I go back to the main screen from Profile, that’s when it hangs. I can go into and back out of all the other options with no problems.

Not sure if I want to fly with the O5.

Is the Fly app the only app you’re running on the phone?

There’s very little else on it, kept it when I last upgraded just for the drone. It’s not resources if that’s what you’re thinking. Tried deleting and reinstalling, no better. Will play with the cache next, the O5 has got a boot time wipe cache option.

Might have cracked it. Clearing O5 cache made no difference but zapping the caches in the app seems to have done the trick.

1 Like

Currently the latest version 1.2.2 is not on Google Play - but you can download and manually upgrade the app via this page on DJIs website.

The ios version has already been upgraded.

You might need to allow your phone to be able to download and install apks.

Might be useful for anyone who has upgraded their drone, but hasn’t been able to update the app.

(I know the link goes to Mini 2 - but the app is the same for both Air 2 and Mini 2 etc)

A post was merged into an existing topic: DJI Mavic Air 2 firmware updates

Strange that the Android version of DJI Fly still hadn’t been updated on the Google Play app store?

To the point now where DJI are even mentioning this in their firmware release notes :thinking:

What gives? :man_shrugging:

1 Like

I noticed that it was on Huawei’s store on my phone - so must be a reason why Google are not allowing it currently.

So might be coming?

It must be coming, but two weeks have passed so far? :thinking:

I wonder what’s so different in the android version as the ios one has been on the Apple app store since release :man_shrugging:

It certainly is a mystery :thinking:

This happened with Go4 once … and only got updated a few days before both iOS and Android went up yet another version.
Chances are someone just forgot to upload to GooglePlay.

:man_facepalming:

They seemingly forgot to update all their web site pages with all their firmware release notes over Christmas too. And even today the Smart Controller page is still showing the September release notes :grimacing:

1 Like

I was unaware that China was SO into Christian themed festivities :laughing: .