Card problems

I did start to write this in the 2018 Golden Hour Challenge but moved it here after my long winded reply below.

I decided it was about time to use Litchi as I’ve owned it for about 18 months now and only flown with it a handful of times, never done any more than just fly manually.
I set up a mission late last night, imported the necessary into Google Earth to check the heights etc, done any alterations to correct the Mavic trying to pass through Twmbarlwm Hill Fort, went to bed at 1am, back up at 5am and off we went, climbed the hill/mountain, took some shots of the first part of the golden hour with the camera, froze my tits off in the 20mph winds, 10 minutes later I got the Mavic out, set it up and off I went in Go4.
I took some great shots with us, (myself and my daughters boyfriend), and the Hill Fort silhouetted against the rising sun, I landed it and changed the battery and shut down Go4 and started Litchi, off I flew towards the start point because I was on the top of the hill rather than where I had planned the mission start.
I hit waypoint and start mission etc, off it went flawlessly with us watching it all the time and I was loving what I was seeing on the screen of the iPad, it finished its mission and I hit RTH which I never do and it came home as it should etc.
When I got home, I put the card in the reader, all 80+ photos and the video pop up on the PC as normal, I click to play a video and that’s where it went tits up.
File explorer closed, no video played, and now the PC is telling me I have to format the card, I have tried all sorts to try and recover the data but nothing yet :disappointed:
The card is now showing in RAW instead of NTFS or FAT32.
I have watched endless videos and tried quite a few things but I’m fearing the worse that all data might be lost :sob:
The card does show as full, I had forgotten to format it on startup, probably because of being a bit nervous about trying Litchi, and it did show as full when it was approaching its last waypoint.
Since trying to watch the video I did try the card back in the Mavic but nothing is showing so I can’t even recover the photos I took with Go4 and the panos etc.
Does anyone have any ideas on how I can recover the footage?

One from the camera.


I’ve used different recovery software successfully getting images off of formatted SD cards. Not sure how well it works with videos though.

Maybe worth giving one a try in trial mode to see if it will work.

1 Like

Great shot Richard
As for the memory card I have a couple of nas drives before working on any photos/videos I always copy files to the NAS and work on them from there
Looks like windows may have tried to make a temp file on the SD card wihile you where viewing

Hope you have luck with recovery software

Bummer! I’ve never had a card go wonky on me … luckily.

I’m yet to find a trial that will do enough without charging big bucks.
I’ll keep the card to one side and hopefully find a solution sooner or later :neutral_face:

Thank you Jeff, I got some crackers with the Mavic if ever I can get into the card.
I normally just transfer the media onto one of my drives and go from there, I was so excited because of the Litchi mission and wanting to see the footage I just clicked on a video to play, I assume Litchi must save in 5 minute files by default maybe :thinking:

You don’t want it either Dave, I’m gutted at the moment, I know some of the shots I had taken were good ones and I was so looking forward to viewing the Litchi video being my first mission.
And obviously, all of the Hill Fort video was planned for what was asked for by @Airchaeology :sob:

Thats true but normally with the trial it scans and lets you know what files are able to be recovered. Might be an indication if the data is still there or the card is faulty.

1 Like

I’m trying one now, I hope it doesn’t make matters worse :zipper_mouth_face:


Shouldn’t make it worse, they don’t modify data.

Hopefully you get a list of files it’s found.

1 Like

Put the card in read only.

I’ve tried all sorts but no luck, it’s being scanned now, hopefully that will find something at least, perhaps it will even correct something fingers crossed.

Well something looks promising if it saves all listed in the above left of this capture, fingers crossed people.


So the data is still there.

Don’t be disappointed if it asks you to pay before showing files.

A few I used gave you 10 files for free.


102 files saved to one of my drives so far so unless it asks after I might be okay :crossed_fingers:


Hope so mate. :crossed_fingers:

I’ve used it a few times but normally after accidently formatting a card.

1 Like

Looks like I have recovered the lot, you all might want to make a note of this, it might come in handy one day.
I never thought I’d ever need it.


Good news! :+1:


All we need now it a look at your Litchi flight
I bought it earlier this year and have planed flights but didn’t have the nerve to let it go so am a virgin litchi owner
Will keep a look out for your thoughts Richard

Thank god it’s all safe


Here’s one …

1 Like

Jeff, I would recommend that you download Google Earth, when you plan your route in Mission Hub you can save what you have done then click on Export as KML 3D Path in MISSIONS bottom left, this will open Google Earth at the point you have planned and show you the heights etc.
I adjusted my heights a couple of times and set them a bit higher as I wasn’t sure how accurate it would be.

Being my first time using it I was real nervous at what it would do, I hadn’t set the camera up properly, I forgot an ND filter but I remembered to press record :rofl:

Here is the Google Earth 3D of my test.

And the Mission Hub route I had planned, it only took about 30-40 minutes to set up which I thought wasn’t bad for a novice and making alterations.

Dave @OzoneVibe can probably give you more pointers as I know he’s used it before.
I hope to get the video up tomorrow hopefully.


Thanks Richard and Dave
I have planned a flight in litchi and transferred into google earth to see the plan in 3d my only worry is the height of trees…they don’t show up correctly in GE
I look forward to your video and I will be contacting you both when I find my balls and use litchi

1 Like