Corrupted flight data sync's and photo/video file created dates and times that are incorrect using DJI mini 3 Pro with RC

Had a quick search but couldn’t find similar issue that I’ve been having since using my new mini 3 Pro with RC.

My mini 3 Pro is updated to the latest firmware, as is the new RC I use with it. I use a sandisk Extreme 256gb microSDXC card in the drone and the same make of card in the RC except its only a 56gb card.

I took some photos and a video today 15/03/23 and when I got home I uploaded the card direct to my laptop via a USB 3 card reader. All was well with the upload but after sorting by date I found todays photos and videos had recorded the date as 09/03/23 with incorrect timings.

I’ve checked the date and time setting on my RC, which is reading correct. When I checked the flight data that had sync’d via the RC it too was showing an incorrect flight details also showing the 9/03/23.

I put the card back in the drone and took a picture with it and checked it in the album and it has todays date stamp! Totally confused to say the least. Same drone, same cards, same RC yet today at 1230ish 2 x photos and 3 x videos all have the 09/03/23 date stamp as does the flight info in my profile but the photo I took 7 hours later has the correct date and time against it in the album?

I’ve had similar problems in the past with this drone, RC and card setup where it’s been two days or one day out but not a week. Never bothered checking the flight data though on these occasions. I thought it maybe down to the memory card but when I saw the flight data was also incorrect but the date etc on the photo was ok after I took it tonight I’m not so sure.

Has anyone had similar issues and if so how was it resolved or have a theory I can work with?

I’ve had the same issue, the way I’ve found to get round it is by using my phone as a hotspot and connecting the RC via wifi before takeoff, it seems to resink the date / time correctly.

I’ve not had this all the time tho just odd pictures, see pics below, these were taken at the same area within 30mins, 2 are in the dark at 10am :see_no_evil: and dates are wrong.

You might be right there as, I connected RC to my internet at home before checking the date. I’ll do that before I go out next time and see what the time/date stamp is correct before flying.

Might change SD card 2. :+1:

Raise a ticket with DJI, it sounds like a software bug

1 Like

Ps. Great photos by the way. :ok_hand:

1 Like

I’d see how you get on connecting the wifi first, might be worth looking at time / date before connecting to see if it’s out, I haven’t fired mine up since Sunday so will look tomorrow.

I might try it on manual mode also instead of network for the time / date settings, looks a common issue when searching it.

I also run SanDisk 128GB Extreme PRO’s in Drone, RC and Pocket2 and had no errors with any of these.

I’ve had similar date issues with my Mini 3, it happened on the 4th March when I went to Groverake Mine. I had no mobile signal in the area when I got home and downloaded the images the date was 3rd March. Switched the controller on and sure enough it was showing 3rd. I connected it to the Wi-Fi and it then updated to the 4th March. Same thing happened not long after I bought the drone.

I would raise a ticket with DJI

This seems to be an ongoing issue that lots are reporting

Thx Mark, Wayne and Jim . It looks like there is an issue and I will add my problem to the others already reported to DJI as soon as I’ve had my porridge. :grin:


Well, with a gut full of porridge I contacted DJI through chat line. Went through usual diatribe of questions and the conclusion for now is the flight logs should sync correctly after connecting the RC to wifi post flight.

Will keep notes on dates I connect RC to wifi over the coming days/weeks along with the actual flight dates and times the RC records.

I wont update RC before I fly but will obviously check dates etc before and after connecting RC to wifi and if the issue persists I’m to report my findings to DJI for resolution.

Suggest anyone else reading this does the same before going to DJI. :+1:

1 Like

I am guessing my controller must have connected to Wifi to upload the logs, they still show as the 3rd March though in Airdata. When I flew again on the 5th March I remembered to check the date and time when I switched the RC on and it was OK for that one.

I have a feeling that the last update did something as everything had been working OK for months but this changed between the 24th February and 4th March when I did an update to the firmware.

@markas Interesting Mark. I updated my RC last night (was only the fly app database) before I took the picture that had showed the correct metadata and obviously after I had connected the RC to my Wifi, but like you, my flight logs remained incorrect after auto-sync. I told them this and said just look at my flightlog from the cloud and you will see the difference!

I’m guessing they may fix this bug in the next update. I am aiming to head out tomorrow if this rain clears away, will check it again then to see if there are any further issues.

I flew on 2nd March but my images were all tagged 1st March for some reason.
After updating the firmware, which I was in no real hurry to do, the date error disappeared…

What was the firmware version you updated too? Would like to compare if I can! :hugs:

This is interesting. Wonder if there’s a link between the probs discussed here and this? ……I tried getting an unlock licence for my Mini 3 Pro 2 days ago. The licence wouldn’t arrive at the Mini 3 Pro controller despite refreshing, disconnecting/ reconnecting etc. I updated the drone’s firmware and flysafe as that was on the Dji list of things to do if there was a problem. Still no joy. Contacted support who sent me the list of how to do it. Found I was doing the procedure as they said. Next step was to send them various screenshots of the controller showing what I was doing. Next reply from support said he had done a custom unlock for me and he hoped all was good. Still no joy! Only then, going into the settings menu on the controller did I notice the time was about 10 hours out. Corrected that and the permissions arrived and installed to the drone instantly!
Support were very responsive. Flew yesterday, nervously, as I had done updates which I hadn’t wanted to do. All good, no probs.

@geoff Interesting indeed Geoff. Did you set date and time manually or let the Wifi update it automatically?

If I remember correctly I set it manually.
Would be interesting to see if others have licence importing probs, and then discover the time wasn’t correct. I was probably just a random glitch, so to speak😂

@geoff I used the auto setup with Wifi for mine. The issue seems more prevalent than I first thought. Fingers crossed :crossed_fingers: that the update I did cures it but I doubt it somehow.

I hope so.

My current firmware is:

Aircraft: 01.00.0450
RC: 01.02.0400

Hope this helps…