DJI assistant 2 and windows 10

#1

So never had any bother using DJI assistant 2 until today. Nipped out for an early morning mess about plugged into windows and now it won’t let me open DJI assistant as it says the admin has blocked it. I’m assuming this is the windows unassigned driver issue but it’s jolly inconvenient. Anyone have any whizzo ideas that don’t involve punching the screen through out front window?

1 Like
#2

Strange. Can’t help, sorry. Mainly because it worked OK on my Win10 laptop last time I used it.

#3

Have you tried running it as Administrator?

Right click on the .exe and select “Run as Administrator” … even if you are logged on as an admin.

#4

I can’t advise as I’ve never used it except to mod aircraft parameters, so I’m curious as to what you use Assistant for? :thinking:

#5

Ok don’t laugh at the philistine but I got all in a dither reading about taking a pano shot and was getting all excited about getting my birds eye badge. Went out early am and took loads of pano stuff but it’s all trapped on the drone and on my phone in the DJI go 4 app and I’m a complete tool and can’t extract the info from the editor to view and get the badge. I fully appreciate that I should just read or watch a tutorial but I’m a man and like to do stuff without reading the instructions

#6

OK - if you’ve not stitched them yet you have two routes.

a) Fire up the MP and use the Go4 app to download the images to your phone and stitch them using the Go4 app

b) copy the files from the SD card and use something like ICE (if you’re on Windows - Microsoft Image Composite Editor - free).

If you’ve already stitched on the phone using Go4, then the stitched 360 image is on the phone, in :
Internal Memory/DJI/DJI.GO.V4/
with a file name “DJI Albumpanorama_nnnnnnnnnn.jpg”

You’ll get a far higher res stitching the images from the SD Card.

On the card, each set of images (and some other gobbledegook) is in its own folder for that Pano in DCIM/Panorama.
The folder name is in the the “date_time_DJInnn” format … where nnn is the logical DJI image sequence number one is used to seeing on the card.

#7

Firstly thank you. Secondly I think I’m gonna need to sit down and go through that at my own pace. I stitched it on the phone but can’t get it from the phone to a viewable computer source. I tried sharing it via email but no good. Will try it step by step and figure out just what it is your explaining. Sorry for being such a total turd

#8

Use the phone’s file manager and head to
Internal Memory/DJI/DJI.GO.V4/

It will be there with a file name “DJI Albumpanorama_nnnnnnnnnn.jpg

Select, and share from there.

#9

Is this the same on iPhone as we don’t have a dedicated file manager as such.

1 Like
#10

Hmm - yeah - they’ll catch up one day. :wink:

#11

Perhaps someone else can say how one can get those Pano files off iOS?

#12

Either way you sir, are a gent for taking the time. I appreciate your help. Is it me or does it not seem a wee bit shite that we pay huge amounts of money for something which does its job fabulously but then seems to come up short on the whole editing and sharing software. (I am on about DJI, not you!!!)

2 Likes
#13

The resolution you get from taking the images off the SD Card and stitching them is so far superior, in any case (for the MP … the M2 does a frigging excellent job!) that after the first few panos I’ve always done it that way.

#14

So Microsoft ICE is probably the way to go in future then. Don’t stitch the images and download straight from the sd card and let the program do the work.

1 Like
#15

It works really well most of the time.

Times when it can struggle are if you’re over large areas of water, large grassy fields, or one’s with uniform crop, etc … where it can’t identify any sharp shapes to perform the alignment.

I know a fix for that situation I describe, and one day I’ll get around to writing up a "How to …. " on it.

#16

I had the OP’s original issue a couple of weeks back when wanting to update the patch on my ronin s, I just uninstalled and reinstalled the assistant and it worked fine.

3 Likes
#17

Out of interest @Pete during the reinstall process were you prompted to grant any extra permissions or anything?

#18

No more than the usual win10 prompt to make the decision as an admin. Then it was all virtually automated.

1 Like
#19

Hi,

I see this USUALLY when there is a new version to download.

cheers

G.

#20

Hi all, I found this via the MavicPilots.com group
https://mavicpilots.com/threads/assistant-2-not-opening-in-windows-10-here-is-the-how-to.63257/#post-724072
It just works, simple (when you know how !)
George

3 Likes