DJI GO and LITCHI both stop upon Mavic Pro connection

Very frustrated. I’m in the pyrenees, which looks like this

And I had a nice shot planned, backing up Mav over a waterfall, and I’ve been hit by forced app closure on both litchi AND DJI go 4.

Seems to happen as soon as controller connects to Mav.

Recently did a factory reset of the phone (Samsung note 8) when I got s screen replaced.

Any idea what’s going on?

Is it a registration thing with DJI?

I’m only here for a few more days so dearly need to get airborne!

I mean… Look!

2 Likes

Stunning location mate.

Have you tried airplane mode?

It’s weird that BOTH apps should crash though.

If you connect the AC and the RC, with no phone, all ok? What if you then connect the phone after they’ve both connected with each other?

Random thought… dodgy cable?!

I’ve not tried airplane mode… I was thinking that as I was wondering about DJI messing with me… Give that a go. I’ve had cable trouble before and got a good one used only for the Mavic so I don’t think it’s that…

1 Like

Are the two apps fighting with each other?

Have you force-quit them both?

1 Like

With neither app running and just connecting the RC to the phone and switching it on (no MP), does Litchi or Go4 automatically fire up?

Yes, auto start on both apps, and I’ve had dji go crash before installing litchi and LITCHI crash after un installing dji go so it’s not a conflict. Hmmm… It’s a puzzle.

Does ONE app auto-start? Or do you get the option pop-up as to which one to select “one time only”?

After dji go crashed when I was up at Cirque de Gavarnie, I spent an hour, AN HOUR downloading litchi on a tenuous 4g connection, only got it to say it couldn’t contact dji servers to register. Since registered but still crashing. I’m traveling now, but will try plane mode later to see if its something from the server messing with it.

That’s I get

1 Like

If you haven’t already, try this sequence …

  • Everything off, and re-boot phone
  • When phone has re-booted (and done all its background shizzle) … Switch on RC
  • Cancel (back button / tap background) the “one time only” message.
  • Switch on MP and wait it to connect to the RC … wait for it to achieve GPS mode.
  • Manually open Go4 or Litchi
1 Like

Roger that. Ok if I include a few “magic swear words” into that procedure Houston?

1 Like

My thoughts a swell !, had a problem like that myself only yesterday (doing some testing) in the garden of certain cables I had.
Found that a “Genuine DJI” cable would not connect on any phone I tried (all 3 of them!)
after several attempts, shut everything down, looked carefully with a magnifying glass, at the connectors on each phone.
Put it down to some shit in the phone sockets.
Sprayed some WD40 Contact cleaner (I swear by the stuff!) in each, seem to have sorted it !.
(ordered some new generation magnetic leads from Amazon)

Ah ha! Interesting. I’ll check that out. And whilst we’re at it, what is French for WD40…? Le WD40?

can’t see why this would cause a drop out ONLY when Mavic connected though… That’s the only weirdness.

(BTW, I’ve ALWAYS used the USB connection on the bottom of the controller since the dji cable let me down in the early days)

1 Like

No!, definitely not WD40 !, it has to there variant of Contact Cleaner, I get it from Screwfix, about £7 ish.

I would ,(as Dave said) close down anything that may be running in the background on your phone.

1 Like

Le Contact Cleaneur?

1 Like

Just out of curiosity Tom?, have you your French Drone registration papers with you?.
I am assuming you are in the French Pyrenees?.

NOPE ! wrong stuff ! whatever you do, do not use that !!

Probably get in in any Hypermarket or Mr Bricolage.

2 Likes

I have used “Servisol Contact Cleaner” in the past, but, not since I found out that it degrades plastic !!