DJI GO4 app crashing when trying to update firmware

Please help been trying to set up my new (1st drone) mavic air to fly in a few days. It seem to download fireware however when drone, RC and app all connect the app turns off, also a precise fly safety data msg to download also shuts down app.
I was thinking could it be because am inside or is it because I live in a no fly zone any ideas please.

Hi @Phil23 are you Android or iOS?

Can you confirm the app itself is the latest version? And no internet connectivity issues in general for that device?

NFZ won’t affect things like this, it’ll simply prevent you taking off, everything else will be normal.

Have you tried updating the firmware using the DJI Assistant software on a computer?

Thank you for you reply.

DJI GO 4 App v4.3.28 I believe, do you have to use a PC / laptop for the DJI Assistant as I tried on my iPhone X and iPad Pro with app. If I need a laptop to try DJI assistant I will rob one from work later and let you know.

Kind regards fingers crossed.

Being inside and being in a FRZ should not cause the app to respond in that way, the drone should take off without GPS indoors and in an FRZ should just refuse to take off entirely.

There are a couple of things you could try;

  1. Remove and reinstall the app (it’s possible there is a corrupt file in there somewhere)
  2. Make sure you have installed the app in phone memory, not on an SD card (some apps are funny about SD cards)
  3. Turn on the controller, start the app then connect the phone (leaving the drone off) to see if the controller firmware will update (it may be the connecting to the drone is causing the app to force quit), after the controller has updated turn on the drone.

Hope this helps… obviously the second point is only if you are using Android as Apple phones don’t have any provision for SD cards (I think?)

I’d recommend doing any FW updates for the drone or the controller with a laptop or PC.

1 Like

Thank you am working of apple iphone x. I believe the controller Fireware worked just when I try to connect drone it starts turning off

I am going to try that later thank you

If you’ve got two different devices experiencing the exact same problems I try a different lightning/usb cable @Phil23 mate - just to rule it out if nothing else.

Ok another thing to try thank you

So using the dji assistant worked and all updated firmware was put on device. However I get this msg now on photo. Saying I need to update precise fly safe on database. When I go to update app turns off.

1 Like

If you haven’t uninstalled/reinstalled the app, I’d try that next.

1 Like

Thinking about doing a full reboot of my phone

I have deleted app and reinstalled I have tried my phone, my iPad and partners phone and the same happens. On the dji assistant it will only open for the drone but doesn’t open anything for my controller. But it is saying the firmware is update on my phone just the app turns off. Am really lost now

Phil you’re only up the road from me (Romsey) so happy to take a look one eve and get you setup?


Thank you Glenn I might take you up on that. I might not be free till Friday afternoon or Sunday, but willing to arrange when your free.

Sorry to hear the problems are still on-going.

Did you try a different USB cable @Phil23? I’m amazed this issue is persisting across devices, kinda says its not the device.

Just uploading a screen recorded

What iOS version are you running here? :thinking:

Does the app have network access in settings?

1 Like

And what happens if you click ignore?