DJI Mini 2 battery won't charge - All four LEDs flashing three times

I went to charge my DJI Mini 2 today.

One of the batteries won’t charge and just sits there with all four LEDs flashing three times, pause, flash three times, pause…

I’ve tried all three slots on the hub, just in case, same issue in each slot. The other two batteries are both charging fine.

Couldn’t find a sequence / reason code online for this, anyone seen it before?

It’s currently still hooked up to the charger on the offchance it’s in a hibernation state or something.

I’ve opened a ticket with DJI but I suspect it’s dead :thinking:

3 Likes

Have you tried charging it by itself out of the hub? Could be hibernation mode? I remember seeing something with the MA2, if your battery was in hibernation mode you had to charge it by itself not in the hub to wake it up (something along those lines, I’ve been to sleep a few times since) :sleeping:

1 Like

I haven’t, no…

Just charge it in the drone you mean?

Would that make a difference? :thinking:

1 Like

I’ve just found this in the Mini 2 manual Rich

Looks like its a damaged battery.

1 Like

I skimmed the manual too :roll_eyes:

I think I was just skimming the light flashing patterns though, not the text :smiley:

Thanks Steve, looks like it’s a deadun!

2 Likes

Yeah you would think a damaged battery warning would warrant a picture of light sequence but apparently it only warrants a tiny line of text :man_shrugging:

3 Likes

Maybe time for a claim against DJI - probably damaged due to the “non-self discharge” saga :man_shrugging:

1 Like

Thats a good call John, worth an email at least

3 Likes

Would think so - even if they only offer a discount on a replacement - better than a poke in the eye :astonished: :thinking: :laughing:

Haha for sure :joy:

1 Like

I’ll see what their support says, if they won’t replace it I’ll just go back to Argos for a replacement :+1:t2:

1 Like

Knowing DJI operate I’m betting you’ll get a better/prompter answer from Argos :+1:

If its down to DJI you’ll probably have to do a video and send to them first :rage: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth:

1 Like

I’ll send them a link to the first post here :rofl:

Anyway, I’ll give them a few days, if no join then I’ll go back to Argos for a swapsie.

1 Like

Have you tried putting the battery into the drone and turning the drone on?
If this works leave the drone running until it connects to the phone/remote. Then turn off and try the charge process again. This worked with mine when the lights were flashing and the battery was not charging.

I did indeed, but it wouldn’t power up at all.

Blows my theory then.
:exploding_head:

1 Like

This might help explain .

2 Likes

Which post on that forum thread?

Even the title looks different to the issue I’ve reported here.

I think Don is talking about the button on the side of the battery bank. Press and hold.

:man_shrugging:

Worth a try.

He might be… :thinking: :man_shrugging:t2:

But no dice there either, was also one of the many things I tried :blush:

1 Like