DJI RC Failure

This is getting silly now. Not my replacement drone, activated it and paired it to the controller and this morning the controller is completely dead. On-off button does nothing - no indication of battery level, nothing - and plugged in to a USB charger there’s no activity from the LEDs to indicate that it’s taking a charge.

Is this a known issue?

1 Like

Seems to be a thing…

DJI RC remote dead,Black screen no power | DJI FORUM

May have to buy an RC-N1 to keep me going while I do another warranty dance…

OK… Panic over. Re-read that thread. Tried the 15-second Power Button Reset. All working as it should. :slight_smile:

1 Like

Always good to know for others :+1:

1 Like

What reset :man_shrugging:t2:

Do you have a link

1 Like

That’s all there is. :slight_smile: Make sure it’s disconnected from any power source. Hold he power button for 15 seconds. In my case, at that point all the LEDs came back on briefly and then a short-long press fired it up again. It’s now charging normally.

The official DJI source for the procedure is in the thread I posted earlier. Note, though, that several other people said they’d tried it and it didn’t work.

If all fails return.