DJI Smart Controller - Firmware updates

A thread to discuss firmware updates for the DJI Smart Controller.


on its way. Its currently in beta :

1 Like

Added support for Phantom 4 Pro v2.0


Optimized the process of selecting the default storage location

Sadly something that’s missing from the CrystalSky. They put two MicroSD slots on it and everything can only use internal memory :man_facepalming:

Reduced the frequency with which the Smart Controller would restart

Erk! Thankfully something the CS doesn’t do :blush:

1 Like

Seems an odd ‘feature’ given the hardware available. It has always baffled me about the smart controller too how DJI launched it seemingly half arsed with the plan being to steadily turn it into a better device over time. :thinking::roll_eyes:

and thankfully this isn’t something Ive experienced yet :wink:

1 Like

A new firmware is out for the smart controller with some neat new features :clap:


  • Date: 2020.01.10
  • Smart Controller Firmware: v01.00.0650
  • DJI GO 4 App: v4.3.28
  • DJI Pilot App: v1.6.1
  • DJI Assistant 2: DJI Assistant 2 For Mavic v2.0.8

What’s New?

  • Added QuickFly function. QuickFly can be enabled in settings. Once enabled, the remote controller automatically enters the camera view of DJI GO 4 after powering on if the remote controller is already paired with the aircraft.
  • Added SkyTalk. Go to DJI Lab under settings to enable. Once SkyTalk is enabled, the live view from the aircraft can be shared with friends via third-party social media apps.
  • Optimized the process of selecting the default storage location. Reduced the frequency with which the Smart Controller would restart.
  • Added audio recording during screen recording. Before recording the screen, go to sound under settings to disable or enable audio recording for screen recording.
  • Added electronic Quick Start Guide for Smart Controller.


  • This firmware version contains important updates, and the Smart Controller can only be updated to this firmware version using DJI Assistant 2. Download the latest DJI Assistant 2, and follow the steps in the System Update section in the DJI Smart Controller User Manual. Download DJI Assistant 2 at
  • Contact DJI Support if the update fails several times.
  • Internet connection is required for SkyTalk.
1 Like


Date: 2020.09.22
Smart Controller Firmware: v01.00.0820
DJI GO 4 App: v4.3.36
DJI Pilot App: v1.8.0
DJI Fly App: V1.1.6
DJI Assistant 2: DJI Assistant 2 For Mavic v2.0.14

What’s New?


Looks like Mavic Air 2 is now supported - no mention of Mini though :thinking: :thinking:

1 Like

Not really surprising. To the best of my knowledge the Smart Controller is Occusync and the MM is WiFi.


Just done mine if I spot anything new I’ll post it here

This is quite significant as it’s the first time the Fly app appears on the SC device.

What’s more interesting here is that the Fly app has only ever been a 64bit app in the past and I’m under the impression the SC is a 32bit device (someone please correct me if I’m wrong).

Where am I going with this? :thinking:

Extract the Fly app from this firmware release and you can then, in theory, side load the Fly app on to the CrystalSky.

I’ll be back :grimacing:


… of course it is :+1:t2: :+1:t2: :+1:t2: — duh mouth in gear brain in neutral yet again - maybe I’ll learn one day :crazy_face: :crazy_face: :rofl:

1 Like

There is an update v01.00.0820 for the DJI Smart Controller which provides support for the Air 2. I don’t have one but use my SC with a Mavic Pro 2 so the update is relevant to me as well.

When you start off the update on the SC (BEST NOT TO, READ ON FIRST) you may well get a number of network errors and the download stops. However if you select Continue Download each time it eventually, at least in my case settles down and downloads with a further hiatus at 99% where further network errors and a very long think occurred. This is where luck steps in. Some users e.g. there is a Billy Kyle video which shows similar behaviour but when the SC restarts the update actually completes. Lucky b******. Mine and others simply goes back to 99% complete and does NOT update.

The solution to avoid this or sort out the failed attempt is to use DJI Assistant 2 for PC or Mac which is now at v2.0.14. As I posted elsewhere my PC would not even see the SC when connected. I remembered that I had similar nonsense when the early January issue update was put out 3 times by DJI until they got one which worked. There was a workaround I found and posted I think here as well as the DJI Pilots forum which involved a factory reset. On this occasion this is not needed.

Assistant 2 will work but only with a couple of arcane settings in the deepest recesses of the SC settings. When that is sorted the SC will be recognised by your PC and you can do the update from there successfully or indeed go back a version or 2 if needed.

The settings in the SC needed are buried in Developers Mode which by default is not ON. This was my issue as it clearly was last time I did an update and looks as though it got reset possibly after the last update.

To enable DEVELOPER OPTIONS, open the Settings screen, scroll down to the bottom, and tap ABOUT REMOTE CONTROLLER and then go down to last item which is a bunch of text headed SYSTEM (or BUILD) VERSION. Tap SYSTEM VERSION 7 times in succession (no I’m not taking the p***) and you will get a message about Dev Mode/Options. Say OK. Now when you back out to the main Settings menu and scroll back to the System section you will find a link setting for Dev Mode/Options indicated by {} Developer Options. Tap that option. Then follows a long list of settings grouped again in sections. You need to find the DEBUGGING section half way down-ish. Then select USB DEBUGGING and set “Debug Mode when USB connected” to ON with a tap. When you do so a pop-up window appears with 3 radio button options. The crucial one you want to set it to is CHARGING ONLY - the first option. This doesn’t seem natural(?) but it is the one you need.

After all this ridiculous kerfuffle you should be able to connect your PC to the SC and use Assistant 2!

I am not aware of any fix in situ for the SC. I also have no idea why some are lucky with an in situ update of the SC. This was exactly the same at the January update. Worked for some not for others so beware of smart ar*** who post “it worked for me”.

Good luck. Who knows one day DJI may get their act together and sort their Android stuff out. I have worked and taught computing since for ever and have sufficient experience to know how to troubleshoot c***. I have no idea how the average Joe who just wants to charge everything up and fly gets around all this avoidable nonsense. Anyway HTH those who get stuck with this.


For those new to all this even if you use Assistant 2 it is not without a suggestion of glitches. There are 3 processes. Download to PC, Transfer to SC and then Update on SC.

You may possibly get the pop-up with the 3 USB options if notifications is ticked in Dev Options. As long as it says Charging Only you are good to go. A bit puzzling why this as if not set correctly the PC doesn’t even see the SC! Anyway it is working if you see it.

I had a network error early on when I decided to stick a network cable into the laptop in case WiFi wasn’t stable. Android/DJI networking is not exactly the best at times, Just clicking Continue was enough to carry on. The 3 stages are lengthy. The last one where the SC updates is very lengthy and can appear to be stuck for periods e.g. mine was on 16% for several minutes and then other %-age estimates could change quickly. At 98% there was a very long pause this was while the SC was doing its updating and re-booting. You will likely get a report that network is iffy and click to continue/sort it out. This is essentially telling you that the contact between PC and SC is temporarily disconnected and the icon for the SC in the PC Assistant also disappears. It will re-appear when the SC finally does its final reboot and initialises and reconnects stably with the PC. At this point you should find all is well and for those lucky to have an Air 2 you will find DJI Fly awaiting with v1.1.6. My Go 4 is at v4.3.36 and controller now at 01.00.0820.

Lengthy post but a lot to take in and a few pitfalls on the way but all good FOR NOW!


In reply to my post on Mavic Pilots someone has knocked up a quick video following the description I gave in my earlier post Video of enabling correct USB settings

This might help re-enforce the description above a little easier. I don’t think he checks whether USB debugging was enabled though. He just shows what settings he already had as Dev Options in his case was already setup and he actually switched it off when he did the 7 taps! and had to re-enable.
It is the USB debugging enabled which is the most likely one needing to set charging is usually the default. That is why you get the message about the low power if you aren’t using the DJI wall adapter as power source.

The best way I found to fix a smart controller stuck at 99% for the version V01.00.0820 and this should work for most smart controller upgrades.
I gather quite a few people are trying to upgrade their controllers to take advantage of Mavic Air 2 Support and getting stuck at 99%.
Firstly don’t try and use WIFI to upgrade as it will take ages.

What you will need is as follows:

    1. Drone – Mavic Pro/ Air etc.
    1. Smart Controller fully charged. (Essential, though the controller will change while connected but at a much slower rate)
    1. USB C Drone to Laptop/ PC cable.
    1. Internet connection.
    1. Patience as this takes a long time to complete.

Enough for what you should have to hand, next:

Turn on the controller and navigate to Settings>System Update, it should let you know what version you are at and whether you require an upgrade.
Check the Storage capacity if there is less that 4Gb of storage then either transfer all your data off the controller or my preference is transferring all data off the controller and Factory Resetting it.
As you don’t have to use the Wi-Fi or DJI GO4 leave these until after the upgrade has been completed.
Remove any SD Cards as well.
If you have Version 1.2.4 (Mac) or 1.2.5 (Win) remove these versions from your Laptop/ PC.
Go to the DJI Software download site, link below

DJI Assistant 2 For Mavic- DJI Download Center- DJI

From the left-hand menu select the appropriate program, download and install the Assistant program.
e.g. for a Mavic 2, Mini, Air 2, 2 Pro or Zoom it will most likely be a DJI assistant for Mavic

Once installed log into the program.

Plug the cable into the controller and PC before powering it up.

You may notice the controller not showing up. I have found that unplugging and plugging the cable back should cure this problem.

You will see the Smart Controller come up, click and click on the upgrade button.

It will go through the following steps

  • Downloading
  • Transmitting
  • Updating

(if the upgrade fails at the updating or transmitting phase it could very well mean insufficient storage)

The Controller screen should be blank at these steps. And it might beep at you.
When it reached 98% the screen should power on.

Things you should be aware:

Cable being unplugged and then reattached as for some reason it may not show up.
The Storage – You must have enough storage for this to work.
Remove the SD Card in case it sets this to the default.
Hopefully this should help with most of the problems of upgrades.
Optional you can set the sleep to 30 minutes

1 Like

Hi All, it should all be here;

@eastsuffolkdrone Simon

What should? :thinking:

1 Like

@PingSpike watch the video I posted above ^^^

No thanks.

Can’t you just tell us what you think should all be in there? :man_shrugging:

Any one on here use the smart controller?

if so have you had an update which has made the controller make you choose a drone to connect to every time you turn it on?

I need to use my old controller and whatever this has done means I can’t connect to that either

Moved your post to the relevant thread.

You need to tell it to connect to another drone, otherwise it’s still paired to the one you want to change. I had to re pair my M2Z yesterday, and I had to pair the SC to my MA2 first, then it was OK to connect the original controller to the Zoom.