DJI Spark set up and connecting


#1

Help anyone. Just had my new spark but following instructions and can’t seem activate drone. Not picking up WiFi etc
Please help


#2

I’m not too sure on spark but if you hang in there someone should be able to help.

Did you get a controller with it? Does it connect to that?


#3

When you first receive your Spark you will need to activate it, here is a guide on how to activate your new aircraft.

  1. Plug the micro USB plug into the rear port of the Spark and charge the drone. …
  2. Turn on your aircraft and connect the drone to your phone/remote with the WIFI network.
  3. Launch DJI Go 4 and login.

Turn on your DJI Spark (one tap and one long press until the fans kick in). Open the DJI Go 4 app on your Android device and tap Enter Device . From there you should be presented with your device’s WiFi menu. Press and hold the Spark’s power button until the drone beeps once, two times (about 6 seconds)

Let us know how you get on.


#4

I’ve got the controller and not emitting any wifi


#5

Have you checked on go ole YouTube for controller pairing


#6

I reckon the controller needs pairing


#7

You can get an App for your phone that detects Wi Fi Signals


#8

When i helped a m8 do his if the controler was red it needed pairing cant remember how we done it now but i think we registered it without the controler then added it after


#9

Think you held the pause and the funtion button at the same time before that you hold the spark for 3 sec and the led blinks red slowly


#10

i set mine up recently, installed dji go4 app, then connected controller to spark then app to controller all using wifi built into the drone & controller, worked out of box, since then i’ve tested different mobiles with it & only one i had a chew on with was a galaxy j5, heliguy has a good tutorial on resetting & pairing the remote.
https://www.heliguy.com/blog/connecting-your-dji-spark-with-the-remote-controller/


#11

can’t get GPS on, what am I doing wrong?


#12

You got it paired then Mike?

And you probably don’t want to fly a DJI drone indoors :blush:


#13

You won’t get a good GPS signal indoors … and certainly, for an initial location fix, it would take some time (if at all).


#14

How did you manage to resolve the previous connection problem?


#15

All sorted, just took some time to connect to GPS. Got it flying and bloody loved it. Was pitch black but just had to take it out. Took it way up and tried sport mode. Bloody hell what a shock. Amazing. Thanks everyone for the help.


#16

Yeah, got it paired and working. Took it out Nd loved it. Did fly indoors a bit too. Kids crying Coz got scared, had to take it back out again. Oh well., :grin::grin::grin:


#17

Glad your sorted, patience is a virtue.
As has been said many times before do not attempt to fly until GPS lock shows green (top left of screen).
"Ready To Fly!


#18

If you could share the solution for others who might have the same issue please @Mikemogs :blush:

Interesting that screen shot showed 10x sats locked on though? And it still wouldn’t take off? Have later GO versions put some safety limits in place? :thinking:

I’m able to take off with any number of sats (even 0) on my setup.


#19

… with a very weak signal … so massive circle of possible location, I’d imagine?


#20

Yup, could be just that I guess :+1:t2:

Should still be able to take off though? :thinking: