Drone-Hacks support, praise where praise is due

Wednesday evening I decided to patch (hack sounds too sinister for something that’s not illegal) one of my DJI FPV Drones. I went with the Drone-Hacks desktop method as it seemed the most straight forward.

I purchased the license (thank you again GDARC member privilege) and set about doing the install. This is where I ran into issues, I could not get the patches to install. Each patch attempt resulted in the message that it had failed. I tried different USB cables, used a second PC that had a virgin install of W10, invoked administrator privileges, all to no avail. Just before retiring for the evening I created a support ticket and then trotted off to bed.

When I awoke the following morning I saw I’d received a reply containing a possible solution. I was instructed to power cycle the drone three times and then attempt the install. To my surprise it worked and the install was complete.

This morning I had a few more questions so I sent an email. Before I’d had chance to finish boiling the kettle for my first coffee of the day I had a reply with very concise answers to my questions.

So in summary, Drone-Hacks gets the two thumbs up (:+1::+1:) award from me for both the product and the post sale support that was provided.



When I purchased & activated my DJI FPV it was on the 020 firmware.
I purchased a Drone Hacks license for the purpose of enable FCC. But I was unable to get it to work.

I tried downgrading & flashing the recommended firmware onto the drone. But the DJI FPV Goggles were showing the camera image but reporting “aircraft not bound to phone number”. I couldn’t start the motors at all. I couldn’t apply any of the hacks. The DJI FPV drone was in a constant reboot loop.

Stressed that I’d bricked by £1500 drone, I re-connected the DJI iOS Fly app and flashed 015 firmware.
I since came across https://drone-tweaks.com to enable FCC (and only FCC … not the other goodness you get from DH) on the DJI FPV

I’m a complete technical noob. I’ve been seeking a up to date YouTube video/guide/tutorial/walkthrough of exactly how to do this step-by-step. I’ve not found one.

According to DH, it appears they’ve found a way to downgrade FW 015 to the recommended one. But I’m very scared of trying that incase of bricking my drone.


That’s good news.

Downgrading the firmware isn’t too difficult, as long as their servers are functioning correctly. At the time I downgraded mine I think the servers were having issues so my way round it was to:

  1. Download the firmware directly from the the repository to my computer.

  2. Using the Drone-Hacks desktop APP, and while logged out of my account, I installed the recommended firmware from the directory where I saved it. This completed without any issues at all.

As I mentioned above in my original post I did have issues installing the patches. It was explained to me that sometimes the DJI FPV Drone can become stuck in a reboot loop. The way to fix this is to power cycle the drone three times and attempt the patching again. This worked for me and the patches, like the firmware, installed without any issues.


As an update. I was able to take advantage of the Drone Hacks solution for my DJI FPV. I was able to downgrade my FPV from 01.02.0015 to 01.02.0000 (via 01.02.0014)

I did this on a 2017 MacBook Pro using bootcamp and running Windows 10. Unfortunately, this must be run natively either Windows or Linux.

Writing my procedure as I was getting in a right pickle. I personally find the documentation of Drone Hacks makes assumptions.

Important note:

Do not power on the DJI FPV Googles or controller. Only the drone.

  • I installed DJI Assistant 2 For Mavic - Download Center - DJI
  • Used a battery with 100% charge
  • Power cycled the drone.
  • Waited 30 seconds
  • Launched Drone Hack Windows app
  • Connected Drone to Mac via a the Apple USB C cable
  • Downgraded from 0015 to 0000 (via 0014)
  • I then applied the FCC hack