Front LED,s not on

I took the drone out to film some fireworks tonight and when I started it up the front red Let’s came on for a couple of seconds then went out. I took off hovered about 10 ft off the ground but still the reds won’t flash so brought it back down as I needed all the help I could get for my first night flight.

When I looked at the settings there is no option to turn them on or off now. I know it used to be there but it’s not there now.

Now I know the last time I powered it up in the house to adjust settings they worked cause the wife was complaining about the flashing. All I have done since the last power up is update the app and calibrate the IMU.

Anyone else noticed this or am I just being really thick and looking in the wrong place. Needless to say I didn’t get any firework footage tonight

What model of drone were you flying?

You’ve got me wondering now @GrahameRob

I’m pretty sure mine turn off as soon as I take off? :thinking:

So yes, they’ll always be on while doing configure stuff on the kitchen table. As you do :wink:

Mavic Pro I’m talking about by the way :+1:

Mavic Pro

I think the Mavic Air ones turn off once you start video recording.
Would not like to swear to that without checking !. I am sure there is a on/off switch in the settings, as I turned them off last Friday to do the Firework Challenge Video!.

Mine don’t.

They turn off when videoing, and there’s a setting for them to turn off for photos.

I always start recording right before I take off - that explains it then :+1:

1 Like

Checking a list of settings that I have, there’s a possibility they are turned off all the time.

Main Controller Settings → Advanced Settings → Other → Turn on Head LEDs (On/Off)

That’s in addition to the one under photo settings that turns them off whilst a photo is being taken.

It’s even possible to set either/both (why would you) C1/C2 to switch them on/off.

Tried power up in the house and still the same, come on for a couple of seconds then go out. Just looked on YouTube and it shows option to turn them on or off but I haven’t got this option

My layout is totally different

You could try setting C1 or C2 to switch them on/off?

Then when they are back on again set C1/C2 back to how you like it.

Incidentally, out of interest, which version of Go4 are you on?

Version 4.3.0

You could uninstall, download the ,.apk for an earlier version and install it.
For various reasons I’ve not gone past 4.2.21 … and that setting appeared last time I looked. I’ll double check for you if you decide to go that route.

Iv just looked and there is a new update so will see if this one sorts it and if not I think I might use an earlier one :+1:

1 Like

All the earlier ones are available on

1 Like

Hmmm …. just checked 4.2.21 and 4.2.16 is like yours.

The easy way … just done it, without uninstalling/reinstalling … is to temporarily change what either C1 or C2 do.
Takes seconds.

Of course - that doesn’t explain how they ended up being switched off … unless one of those buttons is already set to switch them on/off, and you accidentally caught it.

1 Like

@chrisjohnbaker The Mavic air does indeed turn off once you set to record