Gimbal overload

So I flew the Mavic Pro a few times today and on the second and third batteries I was seeing the gimbal overload message upon startup. I did go away after a few seconds and the gimbal worked as expected (although it did reset a couple of times again today).

I was using an ND filter attached the whole time as I normally do… When I got home and warmed up I tried again and now with the ND filter attached it initialises, but at about a 45 degree angle and again I see the gimbal overload message. Without the ND filter I get the message, but it sits straight and works as expected. I can then put the ND filter on (don’t like doing it this way) and it seems ok.

I tried a gimbal calibration with with and without the ND, both times worked successfully but didn’t solve the problem. The thing I have noticed is that upon initialisation the gimbal rotates with way but on one side gets stuck (leaving it at 45 degrees). If I very gently twist it ever so slightly it frees and works normally.

Any ideas or is it time to gable with DJI warranty :frowning:

With power off do all the axis feel smooth and free when rotated by hand?
Remember reading a similar post and one had a tight spot which freed off after rotating manually a few times.
Think it was put down to dirt ingress.

It is pretty smooth, but will stick at the spot when rotated about 45 degrees so I have been trying to blow it out and rotate it. Will try again in a while and see if it helps.

I did think about trying a quick spray of WD, but not if I am going to send it back for a warranty job!

I wouldn’t spray any wet lubricants in it. Can do more ham than good when overspill attracts dust and grit.

If you can feel the tight spot with power off repeatedly move back and forward over it. Hopefully you can dislodge it or break it up if it is some kind of dirt or grit.

Hope you get it sorted mate.

WD40 is the worst idea possible!
Had this with a filter on, and a “nudge” (whilst powered up and pointing in that funny direction) put it back in position for the rest of the flight.
Changed filters and not had the problem since.

Compressed air is your friend here. Just don’t hold it to close. It’s great for getting dirt out of tight spaces.

1 Like

Always have a can, or two, of Air Duster around the house. Invaluable.

I’ll give that a go! Thanks

Switch off the AC and check the Gimbal for free movement. May be some dirt got into the swivel mechanism.

Unfortunately it appears to be a mechanical fault in that then the gimbal rotates clockwise 45 degrees there should be a hard stop, but mine is now a sort of smoothish stop with enough friction to cause the gimbal to become stuck. It is getting stuck most inistialisations and whilst I can free it, it will end up causing more problems so is going to have to go back for repair


Just thought I would add my 2p worth here having experienced gimbal overload on my Phantom 4 Pro. I also got a notification about a firmware imbalance. I bought a couple of extra batteries with it, and have bought 2 more since and I have noticed that the batteries get the firmware update too.

What I have found I need to do is when I have run a battery down to its safety level, I quit the DJI Go 4 app on my ipad. Then when I change batteries and restart my P4P, it does the test for the firmware again.

Once the batteries got their update, no more gimbal overload. Also, no more firmware imbalance either.