Help - meteor75

Hi all,

Had a new experience with my Meteor75 today.

I was planning on experimenting with some different configurations, namely adding Bluejay firmware, and something has gone wrong.

I openend the browser esc configurator and everything was recognized with the original firmware (it was O-H-5-BLHeli_S, 16.80). The FC is the BETAFPVF4SX1280.

I then proceeded to apply the Bluejay firmaware. I selected Bluejay from the dropdown, then kept the O-H-5 ESC, and selected the latest version available. Loaded the firmware and everything went as expected, no errors or nothing. I even applied a different melody to the startup, and it tested ok.

Unplugged everything and went on to test arming and checking if everything was working as it should. Thats when things started to go wrong.

The quad armed but the motors struggled a bit to start spinning, eventually alll started to spin, but motor 1 was not. Went back to the configurator, and tested all motors were spinning on the first screen. Proceeded to read settings so that I could change the min start up power of the motors. Bumped up the setting just a bit from the stock value but still lower than the max, and actually much lower than the original values from betafpv.

Tried again, but things still seemed weird. I managed to arm and get all motors to spin, but it didn’t lift.

I went back to the configurator, but at this point it no longer read/recognized the escs and couldn’t get to the settings. Panic mode on… Sad

I searched a bit and tried to see what a possible workaround could be and read somewhere that flashing fc firmware again could be the way to go. So I flashed the FC, 4.3 release ( I was already running one of the latest development versions before).

Problem still seem to persist. On the esc configurator it still doesn’t recognize escs and motor one doesn’t spin on the first screen.

On betaflight, motor 1 doesn’t spin either. When I plug in the battery, I only hear one beep instead of the usual beeps. Is it likely that I fried the motor somehow as well? I unplugged it from the fc and removed from the frame, did a visual inspection, couldn’t see anything different, apart from a bit of hair stuck around it (which I removed). Anyway to check that the motor is really gone?

I’m at a loss and kicking myself for possibly ruinning a perfectly functioning quad…

Is there any hope? I need some help please.

thx

HI, you can test the motor by swapping it with another and see if the fault moves. if it appears on the same motor it’s your motor thats US
If the fault stays on the same ESC, well you know the rest.

Have you tried using the original BLHeli-S configurator and trying to flash back the original firmware?
Maybe your ESC isn’t ready for BlueJay ?

thx @Steviegeek

I havent tried the motor swap yet, will do shortly

Is the process for flashing with the BLHeli-S straightforward? Do I need to download the esc firmware from somewhere before or would it be available via the interface?

I can’t answer that accurately for you. I’ve only used BLHeli-32 which does have the firmware loadable within the app. Not used -S

I’m sure @Yith or somebody else knowledgeable will be along soon to guide you on that.

Mr Bardwell might have a YT video on it, worth looking
:slightly_smiling_face:

Wah! Me!???

I actually looked at this question and thought… “uh-oh, flashing and config of ESCs … I don’t know that, I’ll keep quiet”

1 Like

Seriously… I know @gunja99 has flashed all his ESCs, as we are reminded every time he starts up a quad… I am sure he can help.

I’m sure he can help you make them play “I’m a Barbie Girl in a Barbie World”… :wink:

I’ll look tonight, if by chance I have a -S floating around I’ll see how you flash new firmware to it

The only issue I can foresee is if the ‘failed’ BlueJay flash stops the esc being recognised

I did the same for once :laughing: Ive never used Blue Jay and even blheli32 Ive not had much experience flashing lol

2 Likes

Almost all my Quads have -S in them and I’ve not flashed a single one. They work, so I don’t mess…

I did see a Bardwell video about flashing Blue Jay a while back and Im sure he mentioned you can either download an app or there is a browser based version you can use with Chrome. Could be worth trying whichever method you didnt use this time? Ill try to find the video and post a link

Heres the Bardwell video :+1:t2:

I seem to never lear that one… lol

I managed to flash all motors using the blheli-s. Used the drop down menu to find a suitable version for mine… On paper its kind of better now.
The beeps are back to normal, escs are recognized on both esc-configurator and blhelisuite.

The quad armed, and all motors were spinning, but no liftoff… thought it might be orientation of motors… but they seem to be as they should. So I dont know now…
At least I know that the motor isn’t busted…

1 Like

Actually, this is one of the videos that prompted me to try it out… lol

total fail

2 Likes

I’ve got the same board:
BETAFPVF4SX1280

MCU F411 Clock=120MHz (PLLP-HSE), Vref=3.29V, Core temp=31degC
Stack size: 2048, Stack address: 0x2001fff0
Configuration: CONFIGURED, size: 3777, max available: 16384
Devices detected: SPI:1

This is a quad I’m having a nightmare with and was going to look at sorting on Saturday with @SirGunner s input, but hey I prefer flying what works when in field, lol!

I just connected, and ESC 4 couldn’t be read!! I tried a few times and rebooted, no luck. All 4 motors did spin though. It did suggest using a different USB cable, which I did, and it COULD read settings.

So here are my settings on there atm. This board came with BlueJay. The same confuigurator should be able to flash BLHeli_S

1 Like

Flashing esc’s are no problem. You just select the latest and flash :man_shrugging:

Cheers my friend… when we meeting next?!

http://esctunes.com/tunes/by/A

Did you try the browser based configurator or the app version?

For reference… This is what mine looked before I messed it up…

The browser version…

This will be relevant if/when @cst3x6 sorts it, but @SirGunner did you suggest turning off bidirectional DSHot (Im running 300)

I’m using the browser version (In chome only), and working fine