Hi all. I could do with some Betaflight help please - Brentwood, Essex

Hi pilots,

I’m based in Brentwood Essex. I’m in need of some Betaflight help if there’s a friendly experienced person around.
Would be good to find some people to fly with too.

Stay safe all

I’m over in Harlow so we’re quite close. I’m a new pilot myself with only a dozen or so how under my belt so not sure how much help I’d be. Still isolating at the moment as well but happy to chat and share what little I’ve learnt. Which drone do you have? I’m a cheapskate and this is my first real drone so it’s only a hubsan zino but I’m really enjoying it so far.

Hi Fishlex,

Thanks for your reply.

So I’m a new pilot, with a new quad, new radio, new goggles, and new frustrations!

I have an iFlight Titan DC2. After connecting my radio to the receiver (crossfire nano), I had no output on the sticks so I flashed the FC board with Betaflight 4.2
It seems it’s flashed ok, configurator sees the correct board but I have no access to any of the tabs. If I click them nothing happens.
I’ve a feeling it’s a communication problem. I’m left with a solid red led, and a flashing blue led. Think I’m right is saying that suggests the gyro needs calibration, which I’ve done but no difference. I installed a new usb 3 PCIe card to be sure I’m working with fairly up to date tech. Still no change.
I’ve tried a couple of different leads, both of which I know are data capable as I updated my goggles and air unit without issue.

I’ve had all the new kit for over a month now and still on the ground : (

Any help gratefully appreciated.

Oh wow sounds like you’re building your own which I’m afraid I have no experience with, I’m a cheap Chinese out of the box pilot. I’m sorry I can’t be of any help.

It’s meant to be a bind n fly!
I’ve learned quite a bit in the last few months of researching products and trying to make the quad I have work.
Clearly not enough though as I remain grounded.

Sounds to me like you have a duff controller, any chance of trying another one?

Unfortunately I only have the one controller that came already installed in the quad.
I do need to buy another one for a plane I’ve just bought, so that’s probably a good suggestion as a way to assess if the current one is working.
Thanks again for your input!

Great news, all sorted! :grinning:
I found a electronics/drone repair guy in Kent and went for a drive.
As I suspected it was a communication and set up problem.
It took a couple of hours but I actually got to try it out in a field behind his workshop.
I can highly recommend his services if anyone else needs help.

Clear the airspace, here I come!


Awesome! See you in the blue pilot.

1 Like