How to root your DJI Mavic Pro, Phantom 4 and Inspire 2 using DUMLRacer and completely remove NFZ

Have you tried something as simple as another cable?

I have no issues on the Macbook, but whenever I use windows its very finicky, and I always have to resort to one usb lead that works.

Might be worth just running a virtual machine on the PC with just Assistant and the bits you need, see if its anything else thats clashing (thats what I do)

1 Like

Excellent idea! Why didn’t I think of that back then?? Spent bloody hours debugging Windows and mucking about with security polices, firewalls and all sorts of nonsense. Still didn’t work…

Could have setup a clean VM in under an hour :roll_eyes:

When there was the free upgrade from Win7 to Win10, I managed to use a genuine install into a Win7 VM to get a genuine Win10 VM.
Once the “machine ID” was registered to the VM, I could then do a clean install of Win10 to a VM.
Every so often I update that clean VM with all the updates, and then clone that for actual use.
So I can have a “genuine” clean Win10 VM up and running as soon as it copies about 25GB. :wink:

I hate windows , more to the point the faffing every update or new bit of software entails so I run lots of virtual machines. It’s also saved me lots of ball ache when the kids install shit on the ‘homework’ machine

Kids shouldn’t be allowed on internet they don’t do homework they just go on social media,get them some encyclopedia’s instead :rofl:

Literally all the 13 year old’s and the majority of my 10 year olds homework is google docs based.

Father in law sent some over, its like ancient scrolls, some of the stuff in there, and a lot of it is most likely liable in todays modern huggy feely (snowflake) culture ;o)

1 Like

Well would you Adam and Eve it…

1 Like

morning all So I’m trying to figure out why the i2 when on the latest fw would give a message incompatible modules when the NFZ data base had been removed so clearly it’s to do with DJI locking everything down on the latest versions, we rolled back the fw to before the anti roll back was introduced and the i2 was unlocked from incompatible module lock down.
We have precise flysafe database at 00000 but app and basic database didn’t zero out when removing precise data base could anyone shed some light on this ? One of the pictures is off here with the data base at zero and the other is my fw versions . Any help would be appreciated.

Hello Again ,
Sorry for the long delay on my reply .
I manage to set up and running the P4 on the terminal with ADB : )
finally got it working on Mac and in Ubuntu terminal .
But I cant remove the NFZ yet .
I got the ADB enabled with DUMLdoreV3 .

These are the Errors I got in the process .

:~$ adb shell
root@wm330_dz_vp0001_v5:/ # mount -o remount,rw /amt
root@wm330_dz_vp0001_v5:/ # cd amt
root@wm330_dz_vp0001_v5:/amt # rm -r nfz
rm failed for nfz, No such file or directory

here is the directory

127|root@wm330_dz_vp0001_v5:/amt # ls

And also , when I want to find out the 0905 part to remove , I cant find any that matches in the backup folder .

root@wm330_dz_vp0001_v5:/data/upgrade/backup # ls

Hope anyone can Help me on this .
The Phantom 4 has firmware version 01.02.0503 and now Im trying with version 01.02.0602 .

Thx all for the Help !!!

Alex .

Hello Guys ,
Any Idea on this issue Im having ?
Maybe , Im doing something wrong ?
Is there any other way to remove the NFZ from the P4 ?

Any advice would be very appreciated : )

Sorry @Alex063 I don’t have a P4 I order to compare folder structures.

That error would suggest a few possible causes.

  1. The folder was already deleted on a previous attempt


  1. The P4 folder structure is different from the MP and you’re looking in the wrong place


  1. You need to roll forwards from 1.02.x to 1.04.x

Without a P4 here I’m afraid I can’t shed any more light mate :confused:

Thank you PingSpike , will keep trying : )

by any chance do you know how I can install unsigned .ipa on

Ipad ?

I found some mod DJI Go 4 apps , but I cant install

them to give it a try …

Thx again !!

I know some people sign up to Apple Developer for £99 and then publish a beta to themselves :wink:

(Requires the source code of the app though don’t forget)

The only other way is to jailbreak the iPad - but that’s a conversation for an iOS forum, not for here :slight_smile:

Thank you again , and youre right , Its another topic .

Hello Again ,
I tryed to flash the firmware to a newer version as you said ,
but for some reason the update never started .
Just said , tranfering to device .
I was using DUMLdore V 3.10 as always , and now , the aircraft dont link to the remote any more : (
I tryed the process again , but no luck either .
Is there any way to fix this ?
Any advice would be very appreciated : )
Regards .

Hello Guys ,
Any Idea on this particular problem ?
What Im doing something wrong ?

Any Help would be great !!
Regards .

Not so many people have been down this route, unfortunately.
I’m sure anyone that can help will pipe up with suggestions as soon as they’re about.

Thank you Ozone Vibe ,
Hope someone can help on this ,
After the failed updates in the DJI Assistant it reads the number of the firmware but with a - at the end .
in my case it reads , Current V2.00.0106-
and the aircraft cant connect to the controller any more : (

Thx again .

1 Like

I am working with my P4P. If I mod the params in an older FW 1.03.059 and then update the FW using the custom rolled FW to 1.5.0600, will the params stay or do they get wiped out? I can open the Dev Params in DJI Assistant but it will not save any changes to any params. If it has a value of 40, and I enter 50, and drop down to next field, it just goes back to 40. So that is why I was wondering if saving Params in older FW version wold retain settings.

1 Like

You may have already figured this out but I just did my P4P. Here you go:

adb shell ** starts the adb shell so we can work inside the Mavic
mount -o remount,rw /amt ** makes the amt directory read and writable
ls amt ** lists contents of amt folder—nfz folder is located here
rm -r amt/nfz ** removes the NFZ folder and contents—can use command above to list again to confirm deletion
ls data/upgrade/backup ** lists contents of backup folder—905 backup is located here
rm data/upgrade/backup/wm220_0905 *** removes the 905 backup file—use above command to list and confirm deletion