IFlight Protek 25 not binding

Having a few problems binding the above, updated the firmware on both controller and drone which was a headache in its self as my pc has now decided to flagging up Dji assistant as a threat…
Managed to get round that by turning off anti virus.

I have the normal blue flashing light on the controller and red permanent with blue flashing on drone, but no matter what I do I cant tether them…

Iv read you have to tether the goggles first then the controller, but not sure if this is true as I tethered my last one just to the controller, as Im still waiting for the new goggles to become available…

Any help would be greatly appreciated as Im loosing the will to live …


1 Like

Can anyone explain what this means :exploding_head:

Seems Betaflight has lost its motor protocol. Probably due to you flashing the firmware.

If you follow this link:


This is iFlights Google drive with the CLI configuration dumps for your quad. Download the latest version and go to the CLI tab and there should be a button to load configuration highlight the configuration you just downloaded and this should setup the quad as it was in tended out of the factory as if you was unboxing it for the first time :+1:t2:

Hope this helps.

1 Like

If you’re using the DJI Air unit/vista then you’ll want to download the HD SBUS config

If you are using Crossfire then you’ll want to download the HD CRSF config

Ok thats brilliant thanks mate, not sure whats going on…

All seems to stem from dji assistant as that was playing up ??..

Can I ask what the restore button does in beta flight as was tempted to click that :thinking:

1 Like

That will restore betaflight back to its defaults as if the quad hasn’t ever been setup before. As if it’s a brand new flight controller.

Download the correct CLI dump from iFlight for your setup and in the CLI tab there should be a button that says load config from file.

Start by thanking you for your support on this :+1:t3:

Iv managed to upload the CLI dump file, mine is the SBUS config.

Everything seem to go ok, pretty straight forward really the only issue I have now is Betaflight says " Failed to close serial port " and Im still unable to bind my controller to my quad.
This is the procedure Im following which worked on my other one fine?, really starting to think I should of stuck to the camera drone as iv had nothing but hassle since branching out into FPV…

Granted some of it was my own stupidity but a lot of it not…

Turn on controller, wait 10 seconds.

Plug in power to Quad.

Push button on quad VISTA or DJI Air unit (small black button). It changes light from Green to Red.

Press the 3 “CORRECT” buttons on the controller (all held down at same time). Controller will make a beep beep sound and turn green, binding is done.

As always any help would be greatly appreciated …


1 Like

I mean I’m no expert on the DJI HD system as I fly analogue. But first I think all 3 items need to be activated on your DJI account and updated to the latest firmware. Then I believe there is a correct order to bind the 3 items in. I believe that to be Goggles first then the controller.

The start of this video shows the binding procedure. It’s for the air unit but should be the same for the Vista as well.

Hope this gets it working for you :+1:t2:

Cheers buddy, what I might do is re- update the Dji firmware via Dji assistant now iv re flashed the flight controller …

If thats what Iv done,

Will have to do later as got to go bloody food shopping first :roll_eyes:


I know that feeling :man_facepalming:t2:

Just to note the flight controller has a separate USB port to the vista/air unit so make sure when updating the firmware you’re connected to the vista not the flight controller.

I think that was probably your first mistake you flashed the firmware of the flight controller and not the vista. This is what caused you to lose the config of betaflight. Luckily iFlight store all their factory setup files on their Google drive so it was an easy fix.

Cheers Mate

I hear you but defo had the right port for the updating the firmware as its a type C and the flight controller is a Micro B.

Only know this as made that mistake last time :man_facepalming:t3:

1 Like

Cool cool, just checking lol

Let us know how you get on, if still no joy I’ll do a little more digging see if I can find the issue online somewhere :+1:t2:

Just watch captain drone on your setup.its a cool bit of kit you have there @BigDog :+1:

Cheer buddy and its all sorted now thank god, it turned out to be a problem with the firmware… :exploding_head:


Cheers for the support Dean you’ve been a great help :+1:t3:

All sorted now, it turned out to be an issue with the firmware so I re flashed both the controller and the quad and all seems fine…

Just gotta check it in Beta flight now …

Thanks again dean

1 Like

No worries buddy, any time. Glad it’s all sorted :ok_hand:t2: Once all the covid stuff is out the way you’ll have join myself @notveryprettyboy and @Steviegeek for a flight session :ok_hand:t2: we’re only down the road really in Coventry. And we’re always up for a road trip :+1:t2:


@DeanoG60 is the dogs bollocks once again :+1::stuck_out_tongue_winking_eye:


You no it :wink:


Yep sounds like a plan mate :+1:t3:

1 Like

Bennerley Viaduct or Willington cooling towers?

1 Like