Is this a fault?


#1

Mavic Pro here!

I’ve noticed that using standard setting, when I slowly rotate the drone it will sometimes “freeze”. This spoils what would otherwise be a usable panning shot. I’m not flying in high winds and it happens at all altitudes and signal strengths.

I’m pretty sure I’m using a constant stick deflection. If I use Cinematic or Tripod modes it doesn’t seem to happen, so it could just be a settings issue, but I’m wondering if anyone else sees this happen?

Here is a short demo video:


My video stutters -especially visible when panning
#2

Is this both the video from the device and also the video on the SD card?


#3

Yes. What’s more, you can see the actual drone itself pause the rotation for a split second.


#4

Certainly shouldn’t be happening … in any mode.
Can’t really think why the video mode should change the way the MP moves, either … they’re not really connected in any way.

Since you’ve been out taking video as evidence, I guess this is a constant/repeatable problem, too.

If the MP’s quite new, I’d contact whoever you purchased it from and start a warranty claim.

Rather frustrating now we have (intermittent) good weather.


#5

Are you brave enough to try this without GO4 running?

I can’t help thinking it’s a software bug?


#6

Thanks Guys. I’ll run some more tests when I get time - probably Tuesday. I was under the impression that the Cinematic and Tripod modes did affect the way the drone flies - control inputs are desensitized. I’ve just spotted a short freeze on a YouTube tutorial, but it could be a bitrate issue rather that the drone itself.

Out today I was flying in lighter winds and didn’t see it happening, but that might not be related. I’ll try flying with just the controller and also maybe test WiFi mode in case it’s a dodgy stick.


#7

Yaw gain reduced, yes, but that’s something one can set separately and, once flying, shouldn’t impact the ability to maintain a constant rate yaw.
Yaw speed should still remain directly proportional to left stick input without any twitches.


#8

Check cable and plug connections it looks like a temporay pause possible interference? As Spike says looks like software, but i am sure that theres a simple explanation out there. I think the the word i was looking for was glitch. Some aftermarket leads are just awful for quality and screening.


#9

But there are no cables between the controller and … the controller.
Whether the device is connected to the controller, or not, or even badly, won’t cause the the MP to yaw twitchily in response to a constant stick input.


#10

This is probably not what you want to hear but I’d contact DJI.

I’ve never heard of the issue so did some googling. Few people with same issue over on mavic pilots and they had to be sent in.


#11

I am getting this exact issue, and my Pro is currently returned for the second time.

First time they replaced the drone, now they’re looking at the remote as when I tested in WiFi only mode the issue didn’t occur.

PingSpike suggested trying with remote and not app - I haven’t tried that but interested in what happens.

I’ll forward this thread to DJI re my return.


#12

Thanks for that clue. You don’t have a link in you history perchance?


#13

Here’s an example of mine. Start at 2:00.


#14

Colinbm - sorry our posts crossed, I was asking Calum for a link to Mavic pilots :slight_smile:

That’s really clear and it’s interesting it’s you second drone, so the finger points to the controller. I’ll have some time to run a test tomorrow.

Thanks


#15

I figured might not be directed at me. :slight_smile: but should have added in first place.

Either remote or app/device. I’m running on a iPhone 10. You?


#16

Running a OnePlus 3T.

Callum kindly forwarded me some links and I cannot see anyone posting that they had a solution. Of course, they may have had it fixed but not posted.


#17

Not (specific) device then. One of the mavicpilots posts might be me - I posted there. I’ll let you know how I get on.


#18

Have either of you tried flying and recording without a device attached to the controller? If the problem still persists, then it’s an RC/MP issue.

Either of you live near another MP owner who would allow you to pair their controller to your MP? If the problem still persists, then it’s the MP and not the RC.

Edit: I’m near Southampton - happy for either of you to pair my controller and try … if either of you are in this area.


#19

I haven’t but that would be my next test if it wasn’t returned.

The fact that it doesn’t occur on WiFi only may indicate the remote, or could be irrelevant as it’s a separate channel of control.

I’m (normally) in Edinburgh but thanks for the offer. :slight_smile:


#20

I’m in ayrshire, your welcome to try mine. Marionville models in Livingston are authorised DJI repair centre, might be worth speaking to them.

If the RC is indeed the issue it would be interesting to hear when this first happened with you both. From new, after an update?

Are you both on current firmware?

I’d be tempted to roll back the RC firmware a version or 2, see if it persists.