Linking problems

For the last couple of weeks I’ve been having trouble connecting my mavic pro to r/c tried everything then I noticed a small split on my c connector to r/c so tried contacting to bottom of r/c now all seems fine anyone else having similar problems try this hope it helps.

1 Like

Connecting the RC to the MP doesn’t depend on any connectors … or your device. It will connect (or not) just the same without any device.

So - were you having problems connecting your device to the RC?

And you mention “c connector”. The RC doesn’t have a USB-C connector.
So, were you referring to the micro-USB on the left side of the RC to the USB-C of your device?

1 Like

Yes, often the simple, overlooked items like cables turn out to be the culprits when it comes to intermittent or connection problems

Yeah sorry I am new to this it’s the connection on the side of the r/c I know what you’re saying but as soon as I remove the cable from the side and reconnect using the bottom r/c connection it links also the green light under the flap for the s/d card isn’t on until I remove the cable from the side strange but true I’ll try it again tomorrow as it seems to happen when it’s not been used for a few hours

I hope I’ve sorted it I’ll try it again tomorrow as I was getting a bit annoyed taking it out and not being able to fly

OK - yeah - it’s not unusual for that side socket to be damaged if an attempt has been made to insert a charge cable with the plug upside-down.

It charges fine that’s why I didn’t think about the short cable but fingers crossed it is all sorted now.

1 Like

The side socket on mine has survived almost 3 years of use … but is no longer a nice firm/tight fit.
I’m got a new ribbon cable with micro-USB connector to replace it one dark/wet/windy day over the winter.
I’ll post pics/notes when I do, should you ever want to do the same one day.

Cheers for that. Only other thing that happened before this problem was I replaced the spring on one of the front arms don’t know if this could have done anything any Ideas.

1 Like

On one of the MP arms? Nope - that won’t have been the cause of the RC socket issues.

I just mentioned replacing the spring incase it is possible that it could cause linking issues

Certainly it can’t be causing problems that are resolved by using the other USB connector on the RC.

If you continue to get connection problems, however, then that possibly becomes a different issue.

The main problem is Linkin drone to the r/c I am going to try it again tomorrow I wanted to know if anyone had similar problems and what salutations they could share

Try without any device connected.
This eliminates possible issues with the cables/sockets.

Will try tomorrow as I said it seems like after a few hours it won’t connect the small green light next to sd card doesn’t come on

Hi I’ve tried it a couple of times today with & without phone contacted :crossed_fingers:all seems good connecting with no problems


Good news. :+1:

Thanks for your help

1 Like