Litchi app crashes while taking a 360 pano

Thought I’d try out the Litchi 360 pano mode on the Mavic Pro the other day.

All the pano settings were on defaults, except one, I added a 1s delay before each photo - just to let the auto white balance settle.

Anyway, I tried it three times, and every single time it would take something between 10 and 15 photos before the app completely crashed and bombed out. Which interestingly then left my Mavic Pro hovering at around 50m with the word JOYSTICK written on the controller and it left me with ZERO control over the craft! Panic mode ensued… like you do :roll_eyes:

Anyway, has this ever happened to anyone before?

I raised a support ticket with Litchi, first thing they asked was the app version and the drone firmware version, so I think my modded .700 might come back to haunt me here as I can fully see them saying they don’t support old firmware :blush:

Personally I’m not sure if the issue is with my Mavic firmware version or with the Litchi app running on a CrystalSky. If I get time over the weekend I’ll try it on the Inspire and see if it bombs out there too. But even that might not be conclusive as on the Inspire it simply moves the camera through the 360 while the drone stays nailed to the sky.

Anyone else come across this issue when trying a 360 pano? And/or on a CS?

1 Like

Hmmmm …. not tried Litchi panos for a while, but it’s on my list of things to play with.

HOWEVER!!! …. I’ve never had problems with Go4 panos, until yesterday … photos too.

Kind of locks up for about 30 (:scream:) seconds when taking pics … sometimes.
Individual pics and twice in the 360 sequence.

All pics are there ok, BUT log files on the phone aren’t.

SD Card has bags of space, so shouldn’t be writing slowly, and if that was the issue I’d expect some kind of error message and wouldn’t expect the log files to be missing.

Was thinking perhaps I could get the onboard logs … but the files in FlightRecords/MCDatFlightRecords have the ending …FLYnnn.DAT … and whilst the flight is missing (checked the ones from this morning on AirData), there’s no missing flight number in the nnn bit … so, as I recall, since that is key in the onboard logs I can’t see there being one there either.

It actually locks up so that there’s no response to the RC … which was a bit panic inducing when there was no response after the message that the pano had ended successfully.

Tried new, freshly formatted SD Card this morning … two 360 panos … one was OK the other had a 30sec freeze between pics 28 and 29.

Not checked logs from this morning … only just got home.

Also, if this is a reboot scenario, I’m not doing any Litchi missions until resolved!
It might even be losing the home-point. That’s my first thing to check.
Hopefully get out Saturday and do some testing, and check onboard logs, too.
Might need the firmware re-flashing? I guess this can be done with my version somehow.
Rather worrying, though, since this is the first of any type of issue I’ve had in 32 months.

Interesting thing yesterday might be coincidence.

Hangar crashed mid pano (on photo 9 of 23) app just shut itself down.

Three different apps playing about … that have been perfectly ok before. That is strange!

Whenever I’m running Litchi or Hangar the controller displays ‘JOYSTICK’ I believe this is normal behaviour.

A quick flick to sports mode and back gives you control.

I was 1500m away when Hangar crashed on me

1 Like

Never seen it with Litchi.

How very wierd, I’ve noticed it lots of times and never thought anything of it.

Maybe I’m thinking back to Phantom days when you have to switch modes to use Litchi

There are lots of occurrences according to a quick Google search, I shall keep an eye on mine too for a while

1 Like

Had a reply today…

I’m not willing to update my firmware :blush:

I was impressed they went to the effort of trying to replicate the issue though!

I’ll try it on the Inspire next time it’s out and report back if the issue is present there too. Not sure it will be though, as Litchi simply moves the camera through the 360° rather that the drone.

1 Like

I still think it strange that three people had similar issues with different software / firmware / drones … all pretty much on the same day.

I’ve done so many panos (and pics) and never had anything like this issue.
Not had chance to get out and test yet. Weather permitting I shall tomorrow.

I have confirmed that the onboard DAT log file for the flights concerned just don’t exist!
To me - this sounds like some part of the drone doing a re-start … and when taking one photo that froze, the gimbal did move as if that’s what it was doing.

Do you have another device to try it with, too?
I’m all Android, but I do have three very different ones to try.

Also considering deleting all onboard DAT log files … when checking for any missing I did notice that part of the internal memory was almost full (even though it deletes oldest as it goes to make space).

I’ll try both Go4 and Litchi, too … at least if it’s apparent with both, then the problem is onboard/firmware based.

I’ve never looked … but I seem to recall mention of a factory reset?
Does that just re-flash the existing version of firmware on the Mavic?
Is there any better way to re-flash the version I’m using?

So just tried litchi pano and it worked first time no crashes.

However as I previously said it goes into joystick mode (grabbed a quick screenshot for you), RC display was also JOYSTICK.

3 Likes

iOS or Android?

iOS Dave

1 Like

My mavic used to display “JOYSTICK” when hangar 360 had control.

Always assumed it just meant a secondary app had control.

Cant remember if Litchi was the same and was using iPad mini.

1 Like

Perhaps mine does and I’ve never noticed. :man_shrugging:

1 Like

This will now take priority tomorrow morning. I’ll go via Specsavers …

1 Like

Just another quick check in waypoint mode the RC display is WP MODE

Again all fine, all be it on a small cobbled together mission

2 Likes