Lost 5V power on SucceX-E F405

As I may have mentioned elsewhere, my Nazgul didn’t boot up properly last time out, despite having worked at the previous session. I only get the first 3 beeps.

After a little research, I have found that it boots fully when plugged into the USB on the PC, and I have tested and discovered that all the BATT pads on it are registering the input voltage, so I guess its own internal step-down is toast.

Presumably I could fix this with a two quid BEC (if I can manage to find someone who has any stock) fed from a BATT pad, but where do I send the +5V out?

if you can’t, I can send you one, PM me :smile:

or if you want some stock, Amazon have some…

to a 5V pad on the board, hoping the failed original regulator has not gone s/c on it’s output.
If it has, you’ll have to find it and remove it :man_shrugging:

1 Like

Ten seems excessive. :laughing:

Heh. I keep finding uses for my 10… I may run out…

To be fair, I’m not quite so prolific a builder as you. :wink:

1 Like

Thanks for that link, Steve, just added a bunch to my shopping list.

Ditto mine arrived today when they said Monday! Was going to use one, but tbh think I’ll stick with the onboards! Has 3 BECs built in, so fingers crossed clean enough :slight_smile:

It’s always useful to have a few in the bits box.

1 Like

Given that the next best stock I could find was 3 for £6.65 + P&P, I now have these.

I’ve fitted one, bridged the 5V pads on the back, but it only seems to be putting out 1V.

Ah, just seen this review:
image

Would have been nice if they came with instructions for us electronics dunces. :laughing:
I guess this might also explain why it was heating up (using a 6S, as that’s what I had to hand for the soldering).

On a different note, the spare GND pads on the FC did not want to take solder - even with flux pen. I really hate soldering (unfortunately).

Oh well, seems I’ve fucked it. Tried the above and while probing points to check voltages there was a pop and I now have no voltage on the BAT pads, so I guess I’ve managed to fry something.

I noticed with the same product that I DIDN’T need to scratch that, but was in the description. Not wired it to any quad yet, but got bench power to 5V just on the bench. Interesting little product :slight_smile:

Er… sounds like you shorted something… :frowning:

So, have you got this working? I’ve used several of these successfully without issue, though I always have cut that track and also have never gone above 4S.

Well whether you need to or not is going to depend on what the pot is set to. I’d say it’s always best to cut that track.

I cut the track on mine, then soldered the 5v link and it works fine. I’m using 4S
That link to cut is very small though :slightly_frowning_face:

Yes, so no, I don’t. The fact that I no longer have battery power to the FC suggests that the thing that popped was probably on the ESC?

So, it’s potentially the case that in order to save replacing the £25 FC I tried a bodge with a 90p BEC (which actually cost £9 because I had to buy 9 others that I don’t actually need) and may have ended up knackering a £75 ESC. And even if I manage to get the BEC fix working, it sounds like it may not be the best plan if I want to fly 6S anyway.

I’m going to have to think very hard about whether I continue to throw money into this pit. It’s great when things go well, but either through misfortune or my own cack-handedness I seem to be spending a lot of money, and most of my time grounded and frustrated.

I feel for you… I really do… :frowning:

I did say I’d send you one, mate :man_shrugging:

I know you did, and it’s very much appreciated, but I don’t want to keep relying on the incredible generosity of the forum members.

Of course, had I fixed the problem I wouldn’t be bitching about it, I’d be pleased at saving £15 over replacing the FC.

1 Like

Feel for you Jez. It is an expensive and time consuming hobby and tbh at points at the weekend felt like giving up myself. Only so much good money you can throw after bad! Spent 20nquid on conformal paint last week. Madness