Mavic 2 battery won't turn on

I had a flight with my mavic 2 Zoom the other day and landed at 30% I think and now a few days have gone by and I have plugged in a battery to charge however no lights showing even when I press the button. However after importing the photos the battery was at 0% and turned off automatically

How long has it been on charge for?

May have just gone in to hibernation mode - recent thread here: Batteries down to 50%

Shout if it recovers and we’ll merge this thread in to that one.

If not, keep this one going :slight_smile:

1 Like

It’s been on for about a hour or so

Try the press and hold for 30 seconds thing

1 Like

Tried that and it doesn’t do anything

Do you have a car charger you can try?

1 Like

No I dont

I’m out of ideas, sorry.

Might be dead :frowning:

Yes that is exactly what PFS said as well

1 Like

Can you not fit it to mavic, plug in usb to pc? And see if that wakes it up? Or then try assistant 2.

Hey Alex. Any change it was trying to install the new firmware when it died?

Saw this video of a fix if it happens on a Mavic Pro, using DJI Assistant 2 to force the update back on. Might be worth a look to see if the same could be done on a Zoom?

https://www.youtube.com/watch?v=EU8WYKUXOaU

I done that

ok im charging a spare and ill do a refresh of the firmware

1 Like

@JoeC I had a flight with rthat battery after a firmware update though - all was good but not now

Ah, probably not then. Still, worth plugging it in to see if it even sees it. May just be an ex-battery :frowning:

1 Like

ex-battery???

I mean it’s possible it’s dead. :frowning:

1 Like

Im refreshing the firmware do you think it will help?

Can’t hurt. :crossed_fingers:

Remember each battery has its own small update so do it with that one plugged in if you can.

1 Like

In better news, better to die on the kitchen table than mid air ;o)

5 Likes