Mavic 2 Smart Controller Update Issues

I posted the following on Mavic Pilots forum and thought it might be relevant to members here who don’t visit there. Ever since I got a Smart Controller there have be issues and niggles with firmware and GO 4 update issues and here is another one - partially resolved.

I went to charge my SC today and I was notified there was an update to 1.00.0650.

I went ahead with download and install on the SC. Download was OK and update apparently OK except there was a update loop where I was repeatedly offered to update again. The update had NOT been carried out.

On reading the accompanying info regarding the features of the update the very last piece of info was that the update MUST BE DONE via SOFTWARE ASSISTANT and not via the SC itself.

Connected to laptop with Assistant V2.0.10 and attempted to update. Failed 3 times without clear indication of why. Uploaded a log to DJI.

Finally the update was successful despite seemingly to have stopped at 98% in Assistant. The SC now shows 1.00.0650 and 4.3.28 for GO 4. GO 4 is 4.3.29 on other platforms.

However matters do not end there! After update I attempted to connect via Assistant to the SC and no matter how I plug/unplug/restart and restart Assistant I cannot now connect to the SC any longer. I repeatedly get USB device unrecognised. This is on 2 separate laptops with Assistant 2.0.10 which is latest Windows version AFAIK.

So in a nutshell. Updated but longer can connect to the SC via Assistant and looks as though updates via SC itself are not possible.

Ok can it turn on?

SC is updated and seems to work OK with caveat haven’t flown with it.
A post on Mavic Pilots confirms that the update works fine at least with 1 flight…

Another post says that Assistant hasn’t worked for them for 6 months. My experience has always been since day 1 there have been niggles and rough edges with the update mechanism. Always managed to get it to update eventually but on this occasion SC is incommunicado with Assistant which is a puzzling annoyance.

I will later be connecting the M2P to check batteries etc. and see what Assistant does then…

1 Like

Have you tried pressing the RC connect button on the aircraft?

Thanks for suggestion but the aircraft is not an issue. I have successfully connected from PC to aircraft with Assistant 2.0.10 no problem and there are no firmware updates for the aircraft.

The issue appears only to be with Smart Controller and now tried it with a standard Mavic 2 Pro controller and also cannot connect with Assistant 2. It is a USB drivers issue I’m sure, as controller devices are not recognised. It may well be that I am using Win 10 Insider fast ring versions on the 2 laptops at my disposal and that may be messing with the drivers. Doing some research on older DJI problem threads there have been issues going back a while with SC and more recent versions of Assistant where a fix has been to remove a recent version, install an older version and then re-install the newer one. That is claimed to provide older drivers that work. Not tried it as can’t currently be bothered. As long as the update works that will do for now.

I also had no problem connecting my Mavic Air with Assistant 2 which is a completely different software version but again the controller would not be recognised and I could see 2 drivers were yellow flagged in device manager.

It is strange that despite the rider MUST INSTALL with Assistant 2 added by DJI some users have reported it updates OK without doing that. It was not my experience though.

Although the update was supposed to improve streaming ability according to 2 reports there are issues with it. Can’t comment on that as I don’t currently use streaming.

No, I understand that but the button that I’m on about is used to link the remote controller to the aircraft

There is no problem in connecting controller and aircraft. Button is only needed if say connecting a new controller that has not been previously connected. Only used it once when I setup standard controller which I got after the SC/M2P combo to use as a secondary controller.

It is the PC and controller that won’t link via Assistant software.

1 Like

Oh right okay, have you tried uninstalling the DJI Assistant 2 from your PC?

Yes on both laptops and fully cleaned. Re-installed several older versions and removed them with same result.
Will see how it flies if I ever get any suitable weather and then have a rethink.

Looks like I am not alone with SC update issues see this thread on Mavic Pilots. The issue with not recognising controllers(?), not just SC, after the update has been documented by others.

Probably best avoid the update for now.

This is interesting…

I happened to be checking the DJI forum yesteday and noted the new update so plugged in my SC to Assistant 2 but it wouldnt connect, it normally does fine but as I was in the middle of work I didnt bother with starting to troubleshoot the issue with a reboot. I looked at the SC which had unusually already began to down load the update. Updating the SC directly has historically never worked, so expected I expected it to fail and run it later on Assistant 2.

Anyhoo, it worked and 2 reboots later, it shows 1.0.650 as the FW version. However much like your experience and having tried connecting today, it simply will not, it didnt before the FW update. I now cannot connect to Assistant 2 at all. The SC is not prompting for the connection type when plugging in the USB cable where it did before.

As a side note there is a new version of Assistant 2 (v2.10) :

https://www.dji.com/uk/downloads/softwares/assistant-dji-2-for-mavic

DJI really cant just get their s**t together can they?!. Just when the had managed to get the SC pretty stable and functioning well they had to go mess it up.

I havent attempted to connect to the craft yet. I dare not.

I have now got a new little info bar with the word ‘Go’ on the SC screen that I can simply move around by dragging with my finger.

Some kind of craft summary by the look of it:

Upon hitting ‘Go’ it fires up Go4 but the word ‘Go’ is replaced by an icon which im assuming is to do with Skytalk.

Although tapping the icon I get a box that states ‘No recent apps’. Thats useful :rofl: :roll_eyes: :see_no_evil:

**I ought to point out I enabled Skytalk by going into the DJI Lab option from within the settings for the SC and enabling ‘SkyTalk’. I’ll be turning that off till I know more.

It seems to connect to the craft ok. Not tried a flight yet though.

For non Chinese speakers! and there are also details of what the upgrade is supposed to do.
Edit: One post suggests that this update has been so problematic it has been withdrawn.

Really??

DJI have some pretty bad history with their updates. Theyre off the scale.

1 Like

Apparently if you can get Assistant to work (which I can’t!) refreshing the firmware will give a more recent version dated 11th Jan rather than the c*** one dated 6th Jan and that corrects the Chinese SC settings text and possibly a couple of other issues.

This is only available if you can get Assistant to work so I along with many others are currently stuffed.

1 Like

Yeah, looks like me and you are indeed stuffed.

Will have to try connecting my SC upto ankther couple of windows devices🤞 and pray.

Updated mine today it was abit wierd had to connect SC to drone direct to complete
Then went out for an hour mp2 flew fine then at 2nd battery change wanted to update again i selected ok and it performed a short on and off and went ok
I hope i have been lucky :pray:

1 Like

Wish you better luck than I had. Have tried on 3 separate Win 10 PCs with new installs of Assistant. By the way Win 10 Defender is convinced the Assistant is a “severe” virus so I have had to switch real time protection off.

1 Like