Mavic 2 Zoom - Problem Charging Controller

Hi there

I’m having a problem when charging my Mavic 2 Zoom standard controller.

When I bought the drone, I charged the Controller up to full charge and it charged with no problems. I’ve charged a few times since then, but for the past week or so I haven’t been able to charge it at all :confused:

Here is what happens whenever I try to charge with cable on the side of the charger or cable with adapter in ‘front’ of charger;

  1. Cable connects;
  2. ‘Charging’ comes up on the screen;
  3. I leave the controller to charge, after a while (30 mins or so) I come back and there’s nothing on the screen and the Controller hasn’t charged at all.

If I connect to the computer, it just shows ‘Connecting’ - I’ve only tried once and I can’t remember if the screen turns off after a while, but I know it won’t charge.

I’m thinking, if the ‘little tab’ inside the charging port was broken, the Controller wouldn’t light up showing ‘Charging’. The DJI online team recommended updating the firmware to 2.0 - but with the battery at 6% I don’t want to brick my controller.

Has anyone had this problem? Can anyone shed a light on this?

Thank you

Firstly, Jeffrey, welcome to GADC! :+1:

Sometimes one has to really question tech support people.
The RC doesn’t even need to be switched on to charge, so there wouldn’t be any firmware loaded and involved.

I’d agree with you that to try and update it with the battery so low wouldn’t be advisable … although the RC battery level drops quite slowly, so perhaps could be done …. if there was good reason.
(At least they advised you to do this, so if it went wrong then they can sort out.)

Again - since the RC charges whilst switched off, when connected to a laptop it should just charge.
That it’s saying “Connecting” would suggest that the RC is switched on. It should still charge if switched on, obviously.

The little connector tab is a weak point if a charge cable is accidentally inserted the wrong way up - so one has to suspect this could be the issue.

Does your phone recognise that the RC is switched on when connected?

I would try another charge lead, just in case it’s duff.
My Mavic 2 Pro lead lasted all of 3 weeks then went crappy on me !.
I now use a braided lead, and have had no problem.
You could try a Android Phone lead as an Emergency measure, but, make sure you insert it correctly (the rounded side should be facing the front of the controller), to make sure you do no damage to the plastic tab !.

High time DJI moved over to USB c,to keep with times,Is already USB c on the smart controller,so why not on all controllers??:unamused::unamused:

The M2P/Z RC is fundamentally/physically identical to the MP controller … from before USB C had really been adopted by anything. :man_shrugging:

1 Like

TBO ,I nearly always now use the bottom USB Connector and go to my phone or Ipad.
Have gone past trusting the side connector, so ferking flimsy !.
I only use it to charge now.
I have found that having my Ipad Air on a Holder attached to a tripod far more secure, and easier to see for my old eyes.


Lets be honest here Chris,what you really mean is its bloody crap!!!:smiley::smiley::rofl::rofl:

1 Like

You took the words right out of my mouth !, it’s shit !:poop:

1 Like

I rarely walk around while I am flying, and stand (or sit) and find it far easier to have the remote on a neck strap, connected with a 6 ft lead to the Ipad (fitted with a sunshade)
Good view, easy to adjust Go4 when required, and life’s sorted.
May not be to everyone’s liking ,but, it works for me !


Three years regular use on mine without an issue.


Same here Dave on my Mavic Pro, no issues with any of its functions.
Mavic 2 Pro, not so.
I’m not saying its faulty, but. they could have improved so many things.
(connection quality, better quality leads, etc)

1 Like

Cant believe you would say such a thing…OH wait its CJB …:smiley::rofl::rofl::rofl:

1 Like

Or if you put it phonetically CEEJAYBEE

1 Like

You should rename yourself, "I TAKE NO SHIT"ceejaybee,:poop::poop::poop::rofl::rofl: There should really be a badge for that!!!

1 Like

TIHSONEKATI (pronounced “Tyson E Catty”) ,
Hey that’s Japanese is’nt it ?

1 Like

We already have a Plonker badge :rofl:


Still get a new lead Jeffery,
OH, and welcome to the mad house !.
We do (just a bit) go off topic, but, we usually get back, … sometime.

1 Like

WE do?..Oh okay then…:rofl::rofl:

I did say… sometime?

1 Like

Like,what year??:rofl::rofl: