Mavic 2 Zoom too scared to move

So, my second outing an hour or so ago into the countryside.
Turned it all on, needed an update so did that.
All OK - take off.

Got maybe 20 feet in the air, screen froze completely ( Nexus 7 2nd edition one ), brought it down and landed.
Restarted software etc.

Up again - screen froze again.
Drone would not move in the air, not in any direction - sticks did nothing.
It bleeped a few times and started to come down very slowly just on the other side of a nasty thorn hedge. It stopped about 7ft off the ground.

Wouldn’t go up or down or any direction again - now i’m panicking a bit to tell the truth. The controller screen said disconnected i think, as did the tablet screen.
Then after 10 seconds or so i could go up, came back over the hedge and landed. Put it away and came home.
Imagine if it had done that across fields etc , or over water.
I thought i’d have to wait for the battery to make it land.

Anyone else had this ?

Did you put the otg cable into drone and update the drone too buddy ?

I didn’t put a cable into the drone, that was turned on ( without props spinning ) on the floor - I don’t know what it updated - it just said something along the lines of the firmware not being right and needed to update.

Not had your precise problem but I have had various issues with my M2Z connection. I’ve had issues where I could control the movement but not take pictures, and issues with the connection dropping out completely (not a screen freeze, it reported a loss of connection).

Most of these were resolved when I stuck to a more rigid pattern of connecting everything up: power on drone and wait until it’s stable; power on controller and wait until it connects; connect the phone only after everything else is working.

Other than that, you could try a different cable e.g. via the bottom of the controller rather than the side; a different phone; remove/reinstall the DJI Go 4 app etc.

I wouldn’t think it would make any difference, but if you’ve had a firmware update, plug the M2Z into a computer and check it using the DJI software on the PC; check batteries also have the firmware up-to-date as well. But it feels more like a phone problem.


IMO all updates should be done in the comfort of your home and should be regarded as a pre-flight check. On site in cold weather is not the place to be faffing around with updates. If controller, drone and battery need updating that is a huge chunk of battery eating time which in cold weather will not leave you much time for flying. At least your battery will be a bit warmer!

Did you do compass calibration and or IMU calibration. I and many others don’t regularly do these but maybe after a firmware update you should as in a sense its a fresh start.

The instructions provided by @kvetner are a sound methodology for getting a first time reliable connection. Definitely use the USB on bottom of controller.

Indeed as @kvetner suggests I would definitely check the firmware update via PC and the DJI Assistant 2 making sure you have the latest version of it ending in .10 I think. Don’t forget batteries have updates so need to put each battery you have in turn into the drone and it will update if it needs to. I haven’t done this for some time as I think I have not had a recent update. Also check you have the latest GO 4 which I think now is at .28 or .29.

Also as suggested it may well be a phone issue. On the other hand if it worked OK first time out then it is more likely to be that you weren’t connected correctly. Cold can however affect phones and tablets. Sticks doing nothing suggest no connection and possibly low battery warning since it wanted to land itself. Possibly used a lot of juice in updating firmware.

Don’t take fright. We (certainly I ) have all had similar alarms. I have had connection problems in the past which largely were resolved by adopting @kvetner 's methodology.

If it’s any encouragement to you that you are not alone. I am not at all an expert, still learning and still do stupid things. I had a good fly round the other week with my M2P via Smart Controller with a brief warning of poor connection which seemed to right itself and didn’t affect the flight. Brought in to a perfect landing and then embarrassingly noticed I hadn’t set the antennae at all! They were still folded underneath the controller. Not the first time I have done that ashamed to admit. Another thing to emphasise in the check list of things to be sure of before taking off.

Always good especially in cold weather to go up to say 20 feet hover for 30 seconds to warm up and bring it down. They start again with a little left right and yaw movements. If that doesn’t look good you are not Good To Go. If sticks don’t work it should just hover. In your 1st case it did? You could have tried unplugging OTG and re-plugging see if that re-connects. Can also but takes time restart the GO 4 maybe need to reboot phone. Since second time round it did its own thing and tried to land suggests to me you were low on battery and it should have done RTH. The fact it was heading somewhere else suggests compass or possibly sats were not good at take off. Essential you must hear the lady say RTH set or you do it yourself as in emergencies like this no sticks will not be good as it could land anywhere.

Third time lucky! Just do all those checks and you will be fine.

Thanks for the info , i’ll connect it to the PC and see what it says.
All batteries are brand new.
Just bought it and the new flymore kit as well.
I did use the USB port on the controller, will try a different cable and phone or tablet.

Indeed but will very likely all need updating if the drone firmware needed it.

Thank You.

I did pretty much all of those to be honest.
The battery was fully charged just last night and the update only took a minute or so. When I got home the battery still had the first light flashing and three solid lights on it.
The lady did say her bit when I took off, and I restarted the software but then it did it again and the photo screen froze on a picture.
Will work through the list above and see what the computer says.
Thank You.

1 Like

Do you have another device you could try?

Nexus 7 2nd gen is coming up on 7 years old and might not be up to running the newer GO4 app with M2.

You could try turning off caching and reducing transmition quality.

1 Like

Now that’s interesting. Is the suggestion here that the batteries on-board charge controller has a firmware that must match that of both the drone and its controller?

Does that mean that any new battery has to have its firmware updated before it can be used with the drone?

Battery firmware is updated by DJI much less than aircraft firmware.
If buying a new battery theres always the possibility its an older version and you will get a “firmware mismatch” in the app.
It’s quite quick to update.

1 Like

OK, that’s really useful to know. Thanks @callum. Do DJI advertise the need to have battery firmware match the drone firmware or do they just rely on the firmware automation process to update?

1 Like

The firmware mismatch seems to be from the new battery I bought in the flymore kit - first time using it.
Just updated all three batteries using the computer, and also the controller as well.
will see how things are tomorrow.


They just rely on the update process.

Generally a battery firmware will come out at same time as aircraft firmware so it’s just one process and the app will always tell you if there is a mismatch.

If the battery does update along with firmware Its always best to then put your spares in so they can update as well.


It is possible but you might not have noticed when you were asked to update the firmware on site but it did the battery as well if a new one. Likely if the whole package was new.

As I said earlier I don’t recall any battery update last firmware update I did a while back. I tend just to charge/top up my last used battery and maybe would miss out on any incompatibility until on site which as said ain’t the best so will check myself.

1 Like

Yes, it’s annoying to say the least.
It isn’t only DJI that do it when you least want it to happen.
Parrot also do it - i couldn’t even take off one day in a beautiful location because of it and no 4g signal in the hills.
Still, that drone is now in a waterfall.

1 Like

I agree with pretty much everything you’ve said apart from powering up the drone before the controller. If the drone should throw a wobbler for any reason you have no possible way of controlling it.

1 Like

Powering it up doesn’t turn the rotors on, so if the controller fails I can just turn the drone straight back off again.

Not if it should take off you can’t.

Is this an actual problem you’ve had?