Mavic Air 2s and Mini 3 with DJI fly App - Unable to take off Code 30064

Hi there! Wonder if any can help me …

I seen to get a lot of errors on my pre flight check list on the app

( Unable to take off Code 30064 ) it only go away
If I re-boot the drone and app … sometimes it go on again than go away … ready to fly …

Anybody know what this is … ? It’s getting a nuisance to me … thank you

Steve .

Hi there ios or android ?
Sorry also what drone


Mavic Air 2s iOS.

What’s the firmware version?

** Code 10001: Camera malfunction. Repairs required. Contact DJI Support for assistance

  • All you can do is restart the drone. If it doesn’t help, replace or repair the Gimbal camera.

** Code 10016: Camera not calibrated. Image quality can be affected. Contact DJI Support for assistance.

  • Calibrate the camera, if the error persists - replace or repair the camera.

** Code 10022: No SD card. Insert sd card

  • Just insert or replace the card.

** Code 10023: SD card malfunction. Change card

  • Try pulling and inserting back. It did not help - change the SD card.

** Code 30007 & 30008: No GPS signal. Unable to hover. Fly with caution

  • Repair or replacement of the gps module is required.

** Code 30047: Barometer initialization failed. Restart aircraft

  • Follow the instructions of the DJI.

** Code 30049: GPS Module Error. Restart Aircraft

  • Restart the mavic mini. If it does not help, repair or replace the gps module.

** Code 30050: IMU calibration required. Calibrate IMU

  • In the settings, find the IMU calibration function and calibrate according to the instructions. If it does not help, repair or replace the gps module.

** Code 30055: IMU not calibrated. Calibrate IMU

  • Repeat the same steps as with the Code 30050 error.

** Code 30060: Compass error. Ensure there are no metal or magnetic objects near the aircraft and calibrate it before use.

  • If there are definitely no metal objects around mavic mini and calibration does not help - repair or replace the gps module.

** Code 30064: Unable to TakeOff.

  • Make sure that nothing prevents the drone from taking off and that you are in the area where flights are allowed. If all conditions are met, but the error remains - restart mavic mini. Doesn’t help - update the firmware. If again the error - need repair mavic mini ( but here it is need to understand which module is broken, the fastest is the problem in ESC module).

** Code 30168: Aircraft power insufficient. Fly with caution.

  • The error most often occurs in high winds, but it can be due to a worn battery or a faulty ESC module.

** Code 30210: Power system hardware. Restart aircraft

  • Reboot helps. If not, update the firmware.

** Code 30226: Start failed. Restart aircraft and DJI Fly App

  • Follow the instructions of the DJI.

** Code 40002: Gimbal stuck. Check whether gimbal cover is removed and ensure gimbal can rotate freely

  • Be careful. You can burn the suspension motors, if you forget to remove the cover.

** Code 40011: Gimbal calibration error. Restart aircraft.

  • Calibrate the gimbal in the settings. If calibration does not work, replace the gimbal.

** Code 40012: Gimbal unable to connect. Repairs required. Contact DJI Support for assistance.

  • Need to replace the gimbal. Watch the video how to do it.

** Code 40021: Gimbal IMU data error. Contact DJI Support for assistance

  • Repair or replace GPS module. Watch the video how to do it.

** Code 180016, 180031, 180030: sensor error. Contact DJI Support for assistance.

  • Try restarting the drone. If it does not help, the sensors are broken and must be replaced.
1 Like

Are you near or in a FRZ or a silly daft DJI NFZ


Am no where near a FRZ

Trent park , Cockfosters, nth London.

1 Like


Thanks for this Very helpful

My Version on the App. ( 1.6.9 ( 652 )

1 Like

What is the Drones Firmware version, check in the app

1 Like

I did see a video on YouTube gavinhr I think it might be for android only ( app update ) due to errors , which I can’t remember off the back of my head which has been making some of the minis & possibly air2 s play up , not sure exactly what tho , however the guys your corresponding with on here have much more knowledge than me , I’ve just checked iOS and it seems there’s no fly app update for that at present , but as said the guys your talking too are well advanced with tech , hope you get it sorted , good luck , I would have said refresh everything and possibly try a different area , !

1 Like

I’d give this a go, I don’t let iOS update the app automatically, I’ll remove the old one completely clear the cache and data, soft rest then update the app manually.

I had a similar prob ages ago , well it would only go so far so high , I was logged into my account , however we’re I was flying was a temporary FRZ due to construction , which at the time didn’t cross my mind , went home deleted the app re installed went some were else & no problems , I know this does not mean the case for me a case for all , it was showing a code & the rear lights I think kept flashing red , maybe I’m miles away from the original subject but yes refresh everything if all fails but I’m no expert !

Sorry edit was meant to say didn’t know if it was the app or were I was as I was only there a couple of days prior to the above prob , with no probs

Hi all, I’m in need of some help and advice.
I have a week old Mini 3 Pro that has achieved only a few very short flights totalling about 2.65 Km all without any issues. After connecting to my computer with the DJI Assistant 2 and checking for updates my control now gives the “unable to take off” message, when tapping on this message the error code is 30064.
The firmware version for the RC controller is shown as v01.01.0300 and the aircraft firmware shown as v01.00.0300 similar but not a match. I have 3 batteries for this drone and the drone properly recognises all of them showing the status and time remaining. DJI Assistant 2 does not indicate any previous firmware versions for either drone or controller.
I’d be interested to know if anyone else has had similar experience and if they found a fix.
best regards

Hi @Scotty see if any of the above is of any use to you

Try a Compass calibration

Tried a Compass Calibration, made no difference, but thanks for the suggestion.
best regards

1 Like

Raise a ticket with DJI, I have seen many reports of this fault after updating the firmware with the assistant software :scream:

Do a search on the DJI forums for 30064 and you’ll see loads of people with the same issue popping up over the last 48 hours.

I got the error yesterday too. Ive had no issues with my Mini 3 Pro and this came out of the blue after connecting the drone to my PC running the latest version of DJI Assistant to update a battery firmware. Nothing ive tried clears it…calibrated IMU and compass and re-flashed firmware etc.

I’ll wait a few days to see if there’s firmware release that fixes it before i pack it up and return to DJI.

Really really annoying as the new battery was to give me a bit more flight time as i’d taken the drone away for a few days and had planned some awesome places to fly.

Not the first time i’ve had this sort of issue either. Wish DJI would give the nannying geo-lock and region policing a rest and just concentrate on building reliable drones and let the user be responsible for where they fly and leave it at that…

Irritating thing is this is clearly a DJI software issue.

I dont remember a new DJI product that didn’t have simialr issues (since 2015)

I keep telling everyone to hold off updates as DJI cause no end of issues with fly app and firmware updates

I also see they bumped the ARB so you are well and truly goosed :scream:


Thanks for the info regarding the DJI Forum, I checked this out and your spot on, there are quite a few people with exactly the same problem.
This is very annoying, a new drone flown a few short times for only a week then it’s disabled by a software/firmware update. Until there’s a fix its now just a useless piece of kit sitting in a bag.
It would appear that this update was not thoroughly tested before being released, less than professional it seems to me.

Best regards