Mavic air error code 200 failed to take off


#1

Hi all i had a small crash a few days back,drone fell about 5 foot to concrete,when restarted an error 200 appears saying cannot take off,check usb cable,factory rest works ok but downgrade or refresh fails at 100% everytime,ive also black video image on my phone ,no sd card inserted and gimbal status is n/a,gimbal calibrated fine, remote connects to drone fine,could this just be a damaged ribbon cable,anyone else ever resolve this error.
thanks for reading…
John…


#2

Hi John / @John75 - and welcome to GADC!

If the gimbal is recalibrating OK, then the gimbal ribbon cable (the one that usually suffers damage) is definitely OK.

These two would suggest that the video cable that runs through the gimbal is damaged - but I’m not sure that is the only problem, so I wouldn’t necessarily try resolving this before other aspects are working OK.

Have you been using Assistant 2 (from your computer) to try this, or just the RC?
If just the RC, then I’d try downloading DJI Assistant 2 and performing the refresh from there.


#4

Hi OzoneVibe thanks for the reply,I have used the dji assistant windows many many times with no update success,gimbal moves up and down when calibrating and also tilt can be controlled with the remote,as soon as I try to fly I get the error 200 cannot take of,check usb connection …


#5

I’ve been informed this could be a software issue,other people have had more success on a Mac iOS than a windows based pc,anyone with any further info on this error code…Thanks.
John…


#6

Sometimes this is caused by a sd card try changing it to internal storage and aee if that gets rid of the error


#7

I’ve tried another sd card with same issues,just does not recognise the sd card it does mount it on the pc when installed in the mavic air…when sd card is removed same issue…


#8

Can you do a factory reset ?


#9

Yeah can do a factory reset successfully but changes nothing,I’ve been trying to troubleshoot this now for 2weeks …


#10

Have you got anyone round you with a mac you can try


#11

That is what I’m trying to chase down now is a Mac,I’ve read people have had better success with Macs over windows,I’ve tried Mac on virtual machine but dji assistant 2 cannot be run on it due to sse2 error…


#12

Hi @John75

Have you tried a different cable between the controller and the phone?


#13

No I have not tried that one yet,I’m using the dji one that came with the drone,I’ll try that tomorrow ,appreciate your help mate thanks…


#14

Ok bought a new high quality usb c cable with still no luck,after watching videos of the update process mine isn’t updating at all,it stops with update fail right after it finishing transmitting,does not do the update,what up with this thing…


#15

Is the MA connected directly to the computer? Or are you connecting the controller to the computer?
Does the controller battery charge ok when you plug in the charger?
I’m just trying to eliminate a few things that’s all.


#16

Hi Brian I’ve the mavic Air directly connected to the pc windows based, controller battery charges 100%,gets as far as 100% on the transmitting window then fails update…


#17

Hmm. It’s very unusual. It should be updating, connected directly to the pc. I think you’ve tried most things, it sounds like an internal fault with part of the circuit board.


#18

Yeah it def doesnt look good,is there anything else I could try Brian…


#19

I’ve also read someone with similar issues used a Mac iOS and was able to get it updated ok…


#20

The trouble with internet is that there are so many different ideas. His issue might not have been exactly the same as yours, he might have had anti-virus protection enabled so couldn’t update thro windows etc. When I’m fault finding I go back to when the original fault occurred, in this case it was after a crash, there are so many delicate components inside and many many soldered connections. It could be any of them rather than a software issue.
You could try the MAC, it’s worth a try, but there’s thousands of people who use windows, iOS and update with no problems.