Mavic Air no photos

Suddenly my Mavic Air refuses to take still photos. Movie video is fine. Any suggestions please? Thanks.

What happens when you try?

Does it work if you use the button on the RC?

Does it work if you use the button within the GO4 app?

Firmware version, GO4 version, and device operating system please? :+1:t2:

1 Like

Tried both RC & App button, nothing except a short blip noise as opposed to the mechanical shutter sound. I deleted stuff on the phone to free-up space & downloaded update firm ware but still no go. I Googled the issue & folk are saying this is a know problem. However I just tried it for the 4th time & it took a couple of stills then decided not to take anymore ? I scrolled through the gubbins but do not know where the GO4 version is stated. Could this be s simple ‘setting’ issue that I have no clue about?

Sorry if this is a silly question, but you’re not recording video at the same time are you? If so, you won’t be able to take a photo.

On a specific version of GO4?

Are the photos saved to the drones onboard memory,or,to the SD Card?.
I would check that the photos are saved to the SD Card rather than the onboard memory.
Just a thought.
The Go4 version is in Settings “About”

1 Like

Not trying to take photos in video mode so that’s not it. Daft as it sounds I cannot ( try as I might) find the GO4 version, how do I get that info when I bring up the DJI app on the phone? When you say 'device operating system ’ do you mean the Hawei smart phone android thingy? Stop laughing Ping, I can hear you :rofl::rofl::rofl: Chris will tell you I am hopeless at this tech stuff!

I tried finding the setting/about section Chris but that is alluding me ? ( so frustrating) I pop the SD card onto the laptop & there are the videos no problem but no photos. As mentioned when pressing the photo button it does not make the shutter sound as it normally did when everything was working properly, just a little ‘blip’ noise???

Y[quote=“Rob, post:6, topic:9238”]
Chris will tell you I am hopeless at this tech stuff!
[/quote]

Bloody Country Bumpkins !:rofl:
Right, so to find your about.
1 the drone needs to be at least turned on.(remove gimbal cover!)
2 connect phone to remote and start Go4
3 tap the small drone symbol at the top of Go4 screen ,(in centre of screen ,at the top.)
4 At the very bottom of the screen there are 3 dots, tap that and “About” should be right next to the 3 dots.
That screen will give you ALL the firmware of your drone.
These are the numbers of current firmware on my drone, yours should be the same.
Aircraft 01.00.0620
Remote Controller 01.00.0200
Precise Fly Safe Database (aircraft) 01.00.01.16
Precise Fly Safe Database (App) 01.00.01.16
Basic Fly Safe Database 01.00.01.09

From that screen you can check, and update any/all the firmware.
I suggest you check all of them to see if you are completely up to date.

1 Like

Just remind me, was your drone new when you bought it?.

1 Like

My suggest would be to connect drone the the computer, fire up Assistant 2, check firmware, and, if it gives you an option to rollback to a previous version, do so.
Then after you have re-started the drone ( after rollback) ,update firmware back to new.
Just my 5 penneth.

I seem to recall someone having an issue (a bit) like this, and I also think the solution was an uninstall and reinstall of the Go4 app.

I think it may have been @JayForceOne … but could be mistaken.

1 Like

Anything is worth a try, strange that it videos ok?.
I would even try a factory reset, if that’s possible?.

Found the thread : Shutter noise and other issues

Not the same.

I’d still try an uninstall/reinstall of the app - I’m certain I recall that as working for someone.

1 Like

Country Bumpkin! that’s a compliment where I’m from ooh arr !!! :rofl:
Anyway, just to confound the issue the video is now not working. I wondered if the drones internal 8gb memory is full possible not helping so went for the lead that connects drone to pc I discover I don’t have one, just not my day. Assuming there should be one in the box but there isn’t so how do I go aout getting one is another problem. Your idea of re-installing the GO4 app is probably my best option so thanks for your input Chris. To be continued. :+1: oh & yes I bought it brand new .

Thanks OV, will try the re-install & see if that works for starters.

If you bought it new you should have the lead?.
Remember the lead that come with it is dual connection!.
The USB lead has a standard USB lead one end and a smaller Connection on the other with an adaptor fitted.
The adaptor end looks like 2” long but it splits into 2 different connectors.
The connector you need is the one with the adaptor removed !.
The adaptor converts from usb-c to micro usb.
usb - c is what you want.

Thanks Chris, I had no idea it did that ( just checked ) I will have a delve into it later. :+1:

I would connect it to your pc, empty the onboard memory, then give it a try.
I would then switch the Go4 App to use the SD Card in the drone all the time.
You will find it in the camera settings.
If that does not work, I would uninstall Go4 and reinstall as Dave has already suggested.

So, turns out it was a firmware error, now sorted. Put everything back to factory settings. Now I have to fine-tune camera settings as todays flight/video is over exposed but not sure how to do it. I am loath to fiddle with anything for fear of completely stuffing it up. I guess it is the exposure setting I need to tweek?

2 Likes

Glad all is well Rob!, set camera at auto and see what results are like then tweak gimbal speed and yaw rate as discussed before to slow things down.
Just shows that we ALL learn something from events like this that can be passed on to other members.
Need any further help, just ask.
Just search YouTube for gimbal/yaw rate best settings.
Set Video to Auto and Stills Camera the same.