Mavic Pro 2 battery stuck on with two lights

My battery is permanently stuck on, but won’t work.
I bought the mavic from Apple while having my phone fixed.

CN this sort of thing be fixed? Also I’m guessing Apple will say go to Mavic for repairs?

It’s permanently like this.

Have you tried connecting it to the drone, even if it is on ,and updating firmware using a PC?

If I put it on the drone the lights on the drone come on and it bums etc. But the handset says no battery.

Try pushing the battery button, for 1 sec , then again, and see if that turns it off.
Have you tried connecting it to the charger, and leave it charging.
It sounds like a firmware issue to me

Yes in The charger it just stays on 2 bars (half).

What if you connect the USB Adaptor that comes with the kit, and try discharging it from that, with say a mobile phone?.

1 Like

Sounds like a dud battery, I would contact DJI for advice.

I have had a similar problem with a Mavic Pro battery that had two stuck middle lights on all the time.
Connected the drone to the PC, ran a firmware update and it cured it.

2 Likes

They may well say that and that may well work but consumer law states the contract is with the person that sold it to you. How Apple opt to interpret that is a different matter - as in do they take it back and send off or do they directly exchange the unit and send the faulty back…?

Good shout.

I had the same issue with my MP batteries. Had to update the FW

I currently have my phone plugged into it to de-charge it.

I would lower its charge, then re-charge, then connect to the drone and update firmware via PC, NOT PHONE.

1 Like

thanks i didn’t even know a battery needed updating until today. The drone yes, but as battery.

also how do i update a battery via pc?

1 Like

Re flash firmware on drone then insert duff battery it should update the battery

3 Likes

Two LEDs illuminated usually means it has failed during a firmware upgrade.

Stop discharging it and put it back on charge for a bit.

Put it back in drone and connect to PC using Assistant 2 and refresh firmware.

2 Likes
1 Like

DJI Assistant 2 Download for Windows PC, (in software section)

https://www.dji.com/uk/mavic-2/info#downloads

2 Likes

Guys thanks fore all the suggestions on here.
I discharged thew battery by charging a phone and an iPad, then re-charged it.
It stuck at 50% again, but i fitted it into the Mavic and it started up and did its update. Afterwards it let me fully charge it.

All’s well that ends well. Thanks to all the Grey Guys who helped. X

6 Likes