Mavic Pro Compass Error

I recently purchased a second hand Mavic Pro from Ebay as a Training / Currency Drone. When carrying out initial test flight, it required a compass calibration but the calibration failed on the front compass. It turned out that there was an issue with the compass module in the nose which was replaced.

Since it has been replaced I now get a Compass Error every now and again. Further testing it appears that it happens when I am in S Mode and flying at max speed, the nose dips in flight and the compass error message appears and when I reduce speed it clears and all is fine. When operating in P mode it is fine obviously because the nose does not dip as far as it does in S mode.

Looking at my logs on Airdata, it says it is a common problem and the severity is Low Risk.

I have recorded in my logs that the aircraft is not to be used for Operational tasking and just to be used for currency and training flights and care to be taken in Sport Mode.

My question is, has anyone else seen this issue and was there anything they did to fix it?

I’ve had my MP for just over 4 years - and, as yet, and when not next to, or on, something that’s pretty obviously the cause of it, I’ve not had a single compass error.

To the extent that I’ve not once recalibrated mine in all that time.

Do the AirData logs say which of the two compasses (compii?) is throwing the error?

Just wondering if the other one is dodgy.

No it just says compass error, I can only assume it is the compass in the nose as it only happens when the nose dips when it is going maxichat.

But both compasses dip by the same amount at the same time.

It is my understanding, so correct me if I am wrong, there are two compasses, one in the nose and one in the tail of the aircraft.

When flying at max speed the nose of the aircraft points downwards so the tail is higher than the nose.

This is my only logical thought, unless you can enlighten me. :laughing:

But the compass in the rear will also have pitched downward by the same amount.
The two compasses are identical, so the pitch rotation is the same for both.

One option open to you is the fact that the onboard DAT logs are both available and decipherable for the M1P.

You use Assistant2 to copy them to your computer, and a program called CsvView (from to convert them to something legible (a csv file that can be opened in Excel).

The event logs in that file hold far more info than from the txt file you’ll have uploaded to AirData … and it may identify which compass is throwing the error. No promises.

1 Like

I rebuilt a MPP earlier this year which included replacing the front compass module, on testing after rebuild I randomly got Compass error front module, I eventually found the cause to be the retaining screw, on rebuild I used a screw of similar size not realising that the original retaining screw was made of non metallic material the screw I used was metal and so causing interference with compass finding the original and replacing solved the issue…hope this helps

1 Like

That is a good shout, are you able to point out what screw it was?

This is the front compass and its screw …

1 Like

This ended up in a dead end. I got the .dat file and tried to extract it using CSVView but it says I need to use ExtractDJI as the .dat file was generated using DJI Assistant 2. For the life of me I cannot find the Extract DJI download anywhere. Thanks anyway

Ah - wrong method.

You should just be able to use file explorer, once Assistant2 is connected, to locate the DAT files and copy them to your computer.

CsvViewer will then open the files OK.

I removed all the screws of a similar size and used a magnetic screwdriver to identify all the metal ones the one that wasn’t magnetic I used, it is a slightly different colour grey. Another point is if a Magnetic screwdriver was used during reassembly this can also cause the module to become magnetised and throw compass errors.


I tried that as well but I could not find the files in File Explorer, the drive which contains the aircraft data is not accessible.

Gimme a few, and I’ll do some screen shots …


You will have got past this screen …

(Things may appear a little different in the latest version of Assistant2 … because I still use an old version. Later versions only needed for later DJI drones.)

Then, when connected, just click on “Flight Data” in the left panel.

Then open file manager, and you should have a new drive “DJI FLY LOG”

Capture - Copy (3)

Opening this gives you access to the DAT files …

1 Like

These are the only two that appear, both not accessible

Once you click on “Flight Data” … those should vanish, and the “DJI FLY LOG” appears.

I’m afraid they don’t on my machine. :unamused: