Mini 2 won’t pair!

I think my mini 2 is dead!

It powers on, does all the self test stuff but fails to pair with the controller. First time powering it on since successfully using it on Monday night.

Just get the fast yellow flashing light and when attempting to pair by holding down the power button for 4 secs it doesn’t do what it’s supposed too. Can’t even power it off. Have to remove the battery.

Seems a pretty common problem according to some other forums including the main DJI one, but doesn’t seem fixable! Lovely.

Most people that have fixed it suggest the SD needs a format but I didn’t even have one in there at the time and have tried with two different ones and still nothing.

Will fully charge everything over night at the off chance and also try a different cable and different device to see if that makes a difference but thought I’d post here first at the off chance anyone else may have a magic solution before I contact DJI and probably have to send it away. :cry:

1 Like

Could try this:

Thanks. As said in OP I can’t put the aircraft into linking mode. Pressing power for 4 secs does nothing.

Have you tried reflashing the firmware using DJI Assistant and a USB connection to your computer ?

Try this

Thanks both. I’ll take it to work in the morning and let you know how I get on.

1 Like

Doesn’t even register it’s connected to the PC, just sits there with the fast yellow flashing light and have to remove the battery to power it off.

I’ll raise a case with DJI, looks like this is probably going in for repair.

Just check you are not plugging the usb in to early or to late. It has to be in the boot up process when the led is going through its colour changing sequences, normally a few seconds after it powers on

It can be a little tricky to get it right

No dice. tried about a dozen times now. Thanks for trying to help.

Out of curiosity, should the Mini 2 show in devices (on Windows) when its connected regardless. I don’t even get the sound as if something has been connected to USB. Although it does charge when powered off.

It’s odd, the gimbal and everything still rotates fine as I move it. Must be some software bug somewhere.

It should show as a removable drive

Just tried mine and it wouldn’t connect at first! :scream:

I then removed the SD card, closed the program down and restarted and then connected after the start-up tones

It sees it as a USB serial Device and assigns it as a com port

Just checking, have you tried without the SD Card in the drone?

Yup, I’ll post a video shortly that I sent to DJI with the support ticket (just waiting for Youtube studio to finish blurring out my location on the app and my flyer/mobile number before posting a version on here)

Not surprisingly they did the usual follow these steps to pair the aircraft which was shown in the video as I can’t do! (I can see they watched the video as the viewers has gone up) but at least did tell me to fill out the form for returning for repair if those steps don’t work.

Depending on when the authorisation comes through I may be able to get it off today, but happy for any other bright ideas in the meantime. :slight_smile:

It’s slightly worrying as I did nothing different to usual, if they can just brick suddenly. I’m glad I was at home and hadn’t travelled out miles and then found this problem. So will add a ‘check it pairs’ to my routine before venturing off out with it in future. If this keeps happening, I wonder if they will happily take back ones no longer covered by warranty!! It does seem to be a problem. Anyone had issues with Mini 2 not pairing? | DJI FORUM

ETA: Here’s the video, has been done without the SD too. Didn’t bother trying to show them trying to connect to the computer too.

The bird is on its way to Holland. I’ll let you all know what Dr DJI comes back with once they’ve had a look at it.

I doubt you’ll ever find out, they’ll just ship you out a refurb unit when your faulty one arrives with them :confused:

I know it’s too late, I followed your link to the Dji site where I read quite a few posts.

It appears that if you change the micro SD card name the drone will not pair.

Out of curiosity did you change the SD card name?

No, SD cards had never been renamed. Did everything suggested in that post and this one. Tried 3 different SDs all had been in the drone at some point, and formatted them all for good measure. No dice. Even tried an android phone for good measure although am pretty sure the problem is nothing to do with the controller itself or the phone used.

If it was a computer it was if it had done all it’s post tests but the actual OS was missing or corrupt. So they will either reflash it if they can or I guess change the board or just ship a replacement. Hopefully one of those anyway.

1 Like

They’ve confirmed will be ‘repaired’ under warranty. Other than providing a picture of it doing it’s flashing thing they’ve provided no further information other than will take 2-3 business days. I assume either the board will be replaced or they will replace with a refurbished unit!

Refurb. Always a refurb.

On it’s way back. Different serial numbers for the drone and the battery!!