New DJI Mini 3 Pro unable to take off

Hi All

I used to fly both DJI Mini 1 and 2 over many years…

Today I was excited to fly the new DJI Mini 3 Pro first time… however it refuse to take off.
I was certain that all the calibration and pre-flight check were completed, it is also in a recommended flying zone.

Manual disarm has no effect, on-screen “take-off” button will trigger motors shake once, then saying “landing” immediately.

I’ve no idea what is wrong… does anyone know if this is my fault or it is likely to be the drone is badly manufactured?

Any advice for troubleshooting would be appreciated.

Thank you.

Any error codes or a screen recording or maybe Airdata to share with us ?

Strangely… the only error code is warning of disabling camera control while it’s on the ground.
The other issue I experienced is the DJI RC shows black screen… the only way to fix it is to power off /on the DJI Mini 3 Pro.

(As you can see it says “permitted takeoff”)

Have you updated the firmware and the flysafe database?

Yes… it’s updated yesterday evening, updated both RC controller and the drone . But I had lots of trouble activating the it yesterday evening. Kept giving 4091 activation error. But mid night 3am it finally activated….

Here’s a video shows what happens when I try to take off.

The other question I would be asking is why you have no camera feed

No you still have your Mini 2 Rcn1 controller?

1 Like

Do the props start manually if you try the joysticks instead of the automated takeoff?

@PingSpike no, it doesn’t do anything if I try to start with joystick. I’ve also tried to calibrate joy stick as well.

1 Like

@Sparkyws the camera feed seems to work random or sometime just blacked out… I can’t figure out a pattern…

Refresh the firmware using DJI assistance

I think you can do the controller as well

If it’s within 14 days, take it back to place of purchase and ask for a replacement. I’m not sure I’d want to be flying a drone with intermittent issues out of the box.


I’ve tried refresh via DJI assistant, it didn’t help. I think I will have to contact support either getting it replaced under DJI warranty or refresher…

@Sparkyws @firstadekit Thank you for all the help.

1 Like

Just return it to the place of purchase.

Given the sheer number of issues you’ve had already @_mini - this also gets my vote.


While I’m going through DJI support, I’ve noticed that when using the software take off method, the app shows error ‘RC signal lost’. I wonder if it is something strange with the firmware… unfortunately I don’t have a RC1 to test and isolate the issue…

I’ve managed to get through support and they’ve accepted return & arranged pre-paid shipping & collection. I assume this will be a free replacement service rather than a repair service…

1 Like

Why not replaced by the store you purchased from?

It is their issue not DJIs

At least you will get a brand new one, whereas with DJI you might not (but hopefully you will)

1 Like

Who is “they”?

Did you buy it directly from DJI or something? :thinking:

I had similar issues but it was down to massive Wi-Fi interference or I put it down to Wi-Fi. Blank screen and the camera would cut in and out. Would not take off at all.
I was at a friends house. The wireless signal display on the RC was all over the place. Moved 50m from his house back to normal.
Not saying there is too much wireless interference where you are but possibly something wrong with the controller unis wireless system?