St16s not reading memory card

Hi guys
Having a problem getting my St16s to read the memory card when in flight mode 2.0 so camara won’t take vids or pics it’s fine in android I can read right and uncounted and mount it but as soon as I try and Evan read the card in flight mode it’s just grayed out I have tried 3 different cards Evan the scan disc one that came with it but no luck anyone solved this problem?

have you formatted it using the drone . and also check the max capacity the drone will take

Yes done that in the controller as the typhoon h plus hasn’t got a memory slot on the drone all done from the. Controller e

Scratch that just found the slot for camara memory card lol what a plonka

1 Like

Someone didn’t read the manual. :grin:

Didn’t get a manual with this one but have d/loaded one now :stuck_out_tongue_winking_eye:

Don’t worry, happens to us all. :+1:
Remind me one day to tell you about my Toshiba laptop volume control :rofl: :joy: :rofl:
Steve :slightly_smiling_face:

1 Like

Just to point out there is a memory card slot in the underside of the camera. You may want to have a quick look I have put a card in the st16s controller just because

Under neath the cover marked yuneec


Next to the micro USB under the yuneec cover cap. Hope this helps.:grinning:


now that’s well hidden. im not surpised you didn’t find it