Struggling to render without jerky output in resolve

I have been using Final Cut Pro on my Mac mini Adobe advised by @milkmanchris to great (well mediocre) effect.

Just had 20 minutes to myself so switched on the Mac to play with some video clips. Updated the software now Final Cut won’t ruin. So I downloaded Resolve and all is fine until i render the final video clip. Resolution is 1920x1080, 30fps. The same as the native video. The result is like a flick book. So jerky it is embarrassing.

Used iMovie and it looks fine using the same clips.
I used the Final Cut Pro template for rendering (in resolve) and it’s good except its all separate files, not one movie.

Any thoughts before i shell out £300 for FCP?

it’s difficult to pinpoint without more details (model of Mac mini: intel or M1/M2 processor?, OS X version?). but if FCPX won’t run after an OS upgrade you probably need to also upgrade FCPX.
Assuming your hardware is up to the task, choppy video is often down to not having the right codec installed: these usually auto-install when you install FCPX but occasionally you need to reinstall/update just the codecs: Apple Pro Video Formats, Pro Video Formats 2.2.7 (UK)

To try and narrow down the problem you could try exporting your video file as ProRes / .MOV as these are Apple native codecs. (I’m guessing you’re currently exporting as a h.264 or h.265 / .MP4 file? whilst these are smaller in data size they are far more processor-intensive and can sap resources - leading to choppy playback).

As far as Resolve spitting out separate files: in the DELIVER page try selecting ‘single clip’ instead of ‘individual clips’.

If you can provide more info I’m sure the good folk here can provide even better solutions!

1 Like



That template is specifically for creating edited/graded individual clips (in huge Pro-res 4-4-4 iirc) and EDL that can then be used by FCP for further editing. But why would you want to?

Hence …

It’s not supposed to create “one movie” - nor can you create “one movie” using that template.

Use the H264 / H265 templates if you are expecting a single file edited video to upload to YT/Vimeo.

Thanks Dave, my point was more that using this preset, the video is exported smoothly.
It seems all variations I have tried using H264/5 results in choppy output.
I have tried altering resolution and frame rates, all unsuccessfully.

I had this before with the Air2s 4K video and resolve but since then was using FCP, which was a solution suggested by Chris. Now I can’t use FCP I want a solution rather than using iMovie.

Zip a full res H254/254 video (under 100MB) that you’ve created that’s “choppy”, and upload here (or if larger), so that the result can be seen and commented on.

In Prores there isn’t much compression - that means there’s minimal de-compression needed to playback.

With H254/225 - it needs to be decompressed to play back.

For whatever reason, it seems that your system is struggling with that decompression … and it probably won’t matter what you use for editing, you’ll bump into the same problem.

That’s the strange thing. The video rendered in iMovie is H264/AVC/MPEG-4 AVC/MPEG-4 Part 10

So H264 and is silky smooth. I’ll try and upload so clips when I get home.

It’s all a foreign language to me!