The day (17/10/18) I lost the Inspire

Met up with my friend today (@Imleon) for a flight, had the Inspire, P4P and MP with me, I was on my second battery flying the Inspire around trying to get some nice shots of the changing colours on the trees when I lost connection, the trouble was it wasn’t high enough to see (80m maybe) because I did the stupid thing of watching the trees on the screen instead of looking where I was as well :blush:
Anyway, I tried all sorts to get it connected but the screen was just frozen, I eventually pressed RTH which I never do, the last recorded battery percentage on a TB47 was 47%, 10 minutes later it still wasn’t back and I still couldn’t hear it, from memory it was 247m away.
I was using Litchi and the goggles (on and off).
The photo shows a red dot where we were and a yellow dot where I lost signal.
I will continue with the story tomorrow, I need some sleep after today :sleeping:

1 Like

Hope you manage to get some sleep.
I don’t think I could if I was in your shoes.
Hope this comes to a good end.

1 Like

Hope you manage to find it… it must be gutting…

Maybe you could call on local members to do a search and rescue…

1 Like

Jeepers mate, I’m gutted for you. I speak on behalf of everyone that we feel your anguish and we all hope for a happy conclusion.
I’m not sure if it will help, but any chance of getting the data downloaded to Airdata app. At the least it will give a heading and height at the point the signal was lost, or it might just have still been recording the data and be able to locate its approx position.

1 Like

Have you a Airdata map of flight path?.
Soul destroyed for you!.
Wish I was nearer, would bring the “Birds” on mass to search with you !


I feel your pain. Losing a drone is like someone kidnapping your child… hope you find it … best of luck

1 Like

Must feel like your best mate has done a bunk !.
Do’nt give up looking, let’s hope you recover it safely.
Come you guys near, let’s go SAR !

1 Like

Sorry to hear that. Hoping you will recover it.

1 Like

Thanks all, don’t panic, it’s not all bad news, I’m just exhausted.

I’ll continue with this tomorrow after some decent sleep.

I will want to know how to find the flight logs in Litchi though.

1 Like

So sorry to hear, I hope you’ll find it, I had a close call with my Mavic Pro with Litchi on the very first time to use it; I lost confidence with Litchi that day and to date I haven’t used it.

Having said the above, your Inspire should’ve initiated RTH by it’s self on loss of signal and returned home. I hope you find though it’s really sad you’ve lost it…

1 Like

Not when using Litchi. It will continue the mission to completion, since Litchi is deigned to run missions autonomously.
That is the whole point of Litchi - to be autonomous and not be reliant on a connection.

But you’d lost connection. How would it know you’d pressed RTH?

It will have flown, or tried to fly, the remainder of the mission, and then done whatever you had it set to do at mission competition … Return to 1st waypoint, reverse, etc.

You’d lost connection. Litchi won’t have the data after the loss of connection.
See …

It should have the data up to the point of disconnection that you can upload to Airdata.
Ok Airdata’s site it tells you where to find the Litchi data.


Believe me Dave, WHEN it happens to you will just be thinking FUCK, I say when because I always thought it would never happen to me, It’s only a matter of time before it happens to us all.
All the I’ll do this if it happens to me go out of the window and you do panic thinking where the hell is it going and I’ve just lost over £1k.

I wasn’t on a mission, I was just flying with the hope of using Litchi in the future and maybe ditching Go4.
I can’t say if Litchi was to blame but I was in the wrong for flying out of LOS and behind the trees, I suspect this is why the signal dropped.

After watching I don’t know how many videos which feature the RTH in them whether instructional or not most people will press RTH, not knowing in the panic if it was just video or total signal altogether I thought it would come back if the signal was still there or if it had picked up.
Again, I wasn’t on a mission.

It would be good to know what it was doing so any logs I can recover might help me know what went wrong, as I said above, probably me.
I will have a look at Airdata later, thank you for that.

I will continue my experience later, I have to go out this morning.

1 Like

OK - that wasn’t clear.

I made not a single “I’ll do this when it happens to me” comment.

They were all statements of fact as to how it will respond (or not respond) - albeit based on believing it to be undertaking a Litchi mission, in an attempt to help you determine where it might possibly be so that you can hopefully retrieve it.

I was reading that if there is another controller near when using litchi, that it can suddenly freeze or drop out.

Do you have a link to that article?

Not yet. I was reading it on PC at work. (Why not eh, Goya pass the time somehow)Will see if I can locate it when I get back into’t t’office as they say in Yorkshire

1 Like

Ok, so the Inspire wasn’t on a mission, but was the RTH button set for the desired behaviour? The choice being RTH,Hover or Land?
If it was in iether hover or land then there’s a possibility that it’s around where it lost signal and maybe up in a tree.

1 Like

I think you have the wrong end of the stick, that was meant in general to anyone and not aimed at you or anyone in general.
I can’t quote you for some reason on the above.

Hopefully you can survey the area with one of your other drones and locate the Inspire?

Yesterday I wasn’t so far from you (relatively), I could have joined in the search. :+1:

I found it before it got dark, I’ll post all about the experience later.
Where abouts we’re you?