TWRP on Crystalsky

Has anyone ever installed TWRP on a Crystalsky ???

I rooted my Crystalsky (

Then I tried to install the NLD GO 4 app (
But without success. There was not enough free memory to install the GApps.

In a German forum I read that you can delete Apps with Titanium Backup.
I then deleted Instagram, Twitter and Facebook to free up memory. But recklessly also the DJI GO 4 app.

What I didn’t know was, that there was no longer an interface to run apps or do anything :unamused:
Then i installed the NLD GO 4 app via “adb install”. But without a interface there is no way to strart the app :exploding_head:

My last idea now is, to install TWRP to restore the original firmware(

I am grateful for any idea or suggestion :kissing_heart:

I run a few different GO4 apps on my CS but I don’t need to go through any of the steps on that NLD link you provided :thinking:

I use deejayeye modder to roll my own custom GO4, based on what I need it to do.

It will output a .apk file which you can just copy on to a MicroSD card, insert the card in one of the ports on the CS and just install it - zero hassle :thinking:

In retrospect, I also know that :pleading_face:

Now I have to get the thing going again first :pensive:

Can you download this firmware version and install it?

Dank Drone Downloader - Web App

It doesn’t work on the device itself because I no longer have a user interface (I’ll send you a few photos when I’m back home).
And the STOCK-RECOVERY on the Crystalsky has no option to install a ROM.

That’s why I haven’t been able to install the original DJI ROM yet.

When I start my GL300E, only the start screen appears. After a short time it becomes a little darker. That’s it.
I also don’t get into the settings menu when I touch the upper screen tab.

And in recovery mode there is no option to install a new ROM.

I am currently downloading the latest original firmware from DJI. The STOCK RECOVERY from Android only accepts original ROMs from the manufacturer.
Maybe I can install them in recovery mode via SIEDLOAD :pray:

I’ll DM you an invite to the slack group.

Hello, can you shed some light how you installed different GO versions on CS? I have it rooted but even then I can’t remove or reinstall the GO app.
What you do with deejayeye modder so to enable the modified GO app to install? I was thinking maybe if I change it’s name or id so to avoid conflict with the original and recompile it that way?

@niki when you’re re-compiling your modded GO4 app you need to rename the application to “dji.pilot.pad”

There might be an old script in the repo on GitHub that does this for you, can’t remember, not looked at it for many years now.

And I don’t mean rename the APK file it outputs, there’s a manifest file or two that you need to edit :slight_smile:

You can then side load your new apk app on to the rooted CrystalSky and it’ll run quite happily alongside the built in GO4 app (so you’re not replacing or updating that one).

I found that the DJI OS will often try to hide the Pilot app (ie. Your custom GO4 app which is now called DJI Pilot) from view but as you are rooted already you can just unhide it again via terminal:

su -c "pm enable dji.pilot.pad"

1 Like

This is great info, many thanks! I’ll dig in to that, hope this script still exist somewhere on github having in mind how long ago the whole thing started.
By the way I’m looking to sideload older version DJI GO 3, are there some major diferences compared when making it with GO 4?

Not, the principal is largely the same for GO3 :slight_smile:

1 Like

I have found that I can use Lucky Patcher to clone the app on my phone and the cloned passed the install on CS. But I can’t pass the login page as it says “Network Unavailable. Check your internet connection.”
The clonned app works fine on my phone, I can login there. Is there something that I have to do in CS to grant network access to clonned app or this could be by wrong app name in the manifest file?

I think I may have missed something… (or you have) :slight_smile:

Why do you need to clone the app from your phone? :thinking:

Are you compiling the app using deejayeye-modder? Then copying the output apk file to a SD card and inserting the card in the CS, then installing the app from the card?

I’m still looking on the net for the older patches that are for GO3 v3.1.18, I have found the GO3 nosec apk but still looking for the deejayeye patches for this version. Can I use the patches from GO4 v4.1.3 and simply rename the folder accordingly?

That’s why I simply tried to use a cloning app that modifies the manifest file automatically and recompiles the apk so to be able to install 2 same apk’s on one device. I did a clone of the 3.1.10 apk that’s currently installed on my phone and tried to side install that clone on CS which turned out to work instead of the login screen. The lucky patcher is doing modification in the manifest file of the apk but I’m not sure what exactly is changed.

As soon I figure out the patches for GO3 I’ll try to rebuild the app with deejayeye :slight_smile:

I have successfully patched GO4 with DeeJayeye but seems it doesn’t work anymore with GO3 as I’m getting errors when compiling back the apk.

Any idea from where I can get some older version of DeeJayeye that supports GO3?

No, sorry @niki I can’t help with that one.

There’s an open issue on GitHub:

But it’s been open for 4 years now :confused:

Thank you so much for your help! I have learned a lot in the last 2 days.

As the older version of deejayeye is not available the only way to make a GO app with different name is to use other app/soft to make a modified clone of the original app where the only change is the name of the app in the manifest file.

I’m looking now for such an app, and found some like Lucky Patcher but they can’t deal with customization like choosing what the app name will be.

Lastly I’ve tried the AppClone, which by the way is suggested on the retroroms site. While it give the ability to modify the manifest file (paid version + paid small donation + paid manifest addon), to find that they don’t give you full access and some settings can’t be changed like the app name, so I requested and got refund for all those Appclone stuff.

I can successfully decompile the GO3 app with dex2ja-2.x but don’t have the skills to build back the app manually. Actually deejayeye also successfully decompiles the GO3 but can’t bring it back.

My only purpose is to sideload older version of GO3 like v3.1.10 or 3.1.18 on Crystal Sky where the default GO3 is v 3.1.59. I need the older version just to enable the 32 channels mod as this is very useful for my job but I want to use it on the CS too.

1 Like

Hmmm… is Litchi an option? :thinking:

Assuming you’re on a drone firmware that still supports all 32 channels, if the GO3 app is the only thing reducing the number of available channels, it might be worth trying a different app.

Alternatively, is rolling back the firmware on the CS an option? So you then get an older version of GO3?

I have Litchi but it’s not an option as this is for Inspire 1 RAW with X5R camera and Litchi doesn’t see the SSD as well some other important options related to RAW are missing. I’m using Litchi for photo hyperlapses using Mavic’s.

I thought also about going to older CS firmware but honestly the last one works the best from my observations, performance and stability wise.

Still digging around for options, will update here if I found some way :slight_smile:

1 Like

Sorry I can’t help you further, please let us know how you get on and if you find a way around it :slight_smile:

1 Like